Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79409 - kernal OOPS - EXT3 (Assertion failure in journal_commit_transaction)
Summary: kernal OOPS - EXT3 (Assertion failure in journal_commit_transaction)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-11 13:25 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-12-17 00:27:28 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-11 13:25:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; Q312461)

Description of problem:
Here's the oops:


Dec 11 11:36:25 oraweb2 kernel: Assertion failure in journal_commit_transaction
() at commit.c:535: "buffer_jdirty(bh)"
Dec 11 11:36:25 oraweb2 kernel: ------------[ cut here ]------------
Dec 11 11:36:25 oraweb2 kernel: kernel BUG at commit.c:535!
Dec 11 11:36:25 oraweb2 kernel: invalid operand: 0000
Dec 11 11:36:25 oraweb2 kernel: autofs e1000 usb-ohci usbcore ext3 jbd aacraid 
sd_mod scsi_mod
Dec 11 11:36:25 oraweb2 kernel: CPU:    1
Dec 11 11:36:25 oraweb2 kernel: EIP:    0010:[<f883d0e4>]    Tainted: P
Dec 11 11:36:25 oraweb2 kernel: EFLAGS: 00010286
Dec 11 11:36:25 oraweb2 kernel:
Dec 11 11:36:25 oraweb2 kernel: EIP is at journal_commit_transaction [jbd] 
0xb04 (2.4.18-3smp)
Dec 11 11:36:25 oraweb2 kernel: eax: 0000001c   ebx: 0000000a   ecx: c02eee60   
edx: 00002f93
Dec 11 11:36:25 oraweb2 kernel: esi: c2db6ac0   edi: f769b9e0   ebp: f7506000   
esp: f7507e78
Dec 11 11:36:25 oraweb2 kernel: ds: 0018   es: 0018   ss: 0018
Dec 11 11:36:25 oraweb2 kernel: Process kjournald (pid: 17, stackpage=f7507000)
Dec 11 11:36:25 oraweb2 kernel: Stack: f8843eee 00000217 f6abb010 00000000 
00000f9c ed608064 00000000 f68fcf40
Dec 11 11:36:25 oraweb2 kernel:        c2db6b20 00000b6a f727c3a0 00000006 
c01f0eac f71581a0 ed7242c0 eb54e780
Dec 11 11:36:25 oraweb2 kernel:        eb54e720 eb54e6c0 eb54e660 eb54e600 
eb54e5a0 eb54e540 eb54e4e0 eb54e480
Dec 11 11:36:25 oraweb2 kernel: Call Trace: [<f8843eee>] .rodata.str1.1 [jbd] 
0x26e
Dec 11 11:36:25 oraweb2 kernel: [<c01f0eac>] ip_local_deliver [kernel] 0x12c
Dec 11 11:36:25 oraweb2 kernel: [<c0120f3b>] do_softirq [kernel] 0x7b
Dec 11 11:36:25 oraweb2 kernel: [<c010a77f>] do_IRQ [kernel] 0xdf
Dec 11 11:36:25 oraweb2 kernel: [<c010758d>] __switch_to [kernel] 0x3d
Dec 11 11:36:25 oraweb2 kernel: [<c0119048>] schedule [kernel] 0x348
Dec 11 11:36:25 oraweb2 kernel: [<f883f7d6>] kjournald [jbd] 0x136
Dec 11 11:36:25 oraweb2 kernel: [<f883f680>] commit_timeout [jbd] 0x0
Dec 11 11:36:25 oraweb2 kernel: [<c0107286>] kernel_thread [kernel] 0x26
Dec 11 11:36:25 oraweb2 kernel: [<f883f6a0>] kjournald [jbd] 0x0
Dec 11 11:36:25 oraweb2 kernel:
Dec 11 11:36:25 oraweb2 kernel:
Dec 11 11:36:25 oraweb2 kernel: Code: 0f 0b 5a 59 6a 04 8b 44 24 18 50 56 e8 4b 
f1 ff ff 8d 47 48


The server is a Dell Poweredge 1650 with hardware RAID control (RAID 5, aacriad 
adaptec card) . 


uname -a : Linux oraweb2 2.4.18-3smp #1 SMP Thu Apr 18 07:27:31 EDT 2002 i686 
unknown

issue: Redhat 7.3 Valhalla


Please let me know ASAP if there are any recommended patches/updates which will 
cure this problem (which we have experienced several times on similarly 
configured boxes).

Cheers.






Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Comment 1 Arjan van de Ven 2002-12-11 13:28:31 UTC
there have been several kernel errata for 7.3; the very first one of those was
to fix exactly this issue; 2.4.18-18.7.x is the current recommended 7.3 kernel.


Comment 2 Need Real Name 2002-12-11 13:43:14 UTC
cheers.. will do.


Note You need to log in before you can comment on or make changes to this bug.