Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79404 - Estonian keyboard layout broken
Summary: Estonian keyboard layout broken
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
: 80464 (view as bug list)
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-11 10:55 UTC by Jaanus Kivistik
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-21 07:39:56 UTC


Attachments (Terms of Use)

Description Jaanus Kivistik 2002-12-11 10:55:10 UTC
Description of Problem:
Estonian keyboard layout is broken (keys "greater than", "less than", "pipe",
"carot" don't work).


Version-Release number of selected component (if applicable):
XFree86-4.2.99.2-0.20021209.0

How Reproducible:
Selected Estonian layout("ee") try to enter symbols "greater than", "less than",
"pipe", "carot".


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
nothing or " "

Expected Results:
proper symbols

Additional Information:

Comment 1 Jaanus Kivistik 2002-12-13 13:09:49 UTC
"<" seems to be AltGr + "," and ">" is AltGr + "." (which are wrong mappings on
a Estonian keyboard). Mapping of "pipe" is yet to be determined...

Comment 2 Mike A. Harris 2002-12-27 04:05:40 UTC
*** Bug 80464 has been marked as a duplicate of this bug. ***

Comment 3 Jaanus Kivistik 2002-12-27 08:00:14 UTC
Adding "XkbModel" "pc105" to XF86Config-4 fixed all symbols, exept "pipe". Adding 

key <LSGT>  { type[Group1]="FOUR_LEVEL",
                  [      less,    greater,          bar,     brokenbar] };

to pc/ee symbols file fixed  "pipe" also, but I think there must be a cleaner
solution (maybe from a toplevel symbols file?)

Comment 4 Daniel Resare 2002-12-28 14:45:31 UTC
this is also a problem for the swedish (se) keyboard. The suggseted solution
above works for me.

Comment 5 Daniel Resare 2003-01-20 23:05:50 UTC
At least for the swedish keybaord, this is fixed in XFree86-4.2.99.3-20030115.0

Comment 6 Mike A. Harris 2003-01-21 02:10:51 UTC
Is this working for estonian in the XFree86-4.2.99.3-20030115.0 release
or later now?  If not, then please let me know ASAP.

Comment 7 Jaanus Kivistik 2003-01-21 07:39:56 UTC
Seems to be fixed in XFree86-4.2.99.3-20030115.0.


Note You need to log in before you can comment on or make changes to this bug.