Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79402 - Internal compiler error compiling Mplayer 0.90rc1 (mw.c)
Summary: Internal compiler error compiling Mplayer 0.90rc1 (mw.c)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-11 09:57 UTC by Martin Hamant
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 10:53:47 UTC


Attachments (Terms of Use)

Description Martin Hamant 2002-12-11 09:57:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

Description of problem:
Configure command was :
./configure  --enable-gui --language=fr

and "make" do :

(...)
gcc3 -c -O4 -march=i686 -mcpu=i686 -pipe -ffast-math -fomit-frame-pointer
-D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fomit-frame-pointer
-fexpensive-optimizations -fschedule-insns2 -Wall -malign-double -I. -I../loader
-I./wm -I./skin  -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include  -DDEBUG 
-o mplayer/mw.o mplayer/mw.c
mplayer/mw.c: In function `mplMainDraw':
mplayer/mw.c:191: warning: unused variable `type'
mplayer/mw.c:244: Internal compiler error in print_rtl_and_abort, at
flow.c:6458Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
(...)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. get mplayer 0.90rc1 source code
2. ./configure
3. make
	

Actual Results:  compilation crash on mw.c with internal compiler error.

Expected Results:  compilation should have been completed succefully.

Additional info:

Comment 1 Rex Dieter 2003-01-24 15:29:09 UTC
A workaround is to say 
CFLAGS='-O2' ./configure 
to avoid the use of -O4. 

Comment 2 Richard Henderson 2004-10-03 10:53:47 UTC
Mplayer has built since then.


Note You need to log in before you can comment on or make changes to this bug.