Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79396 - RFE recognizing filenames written in script other than latin
Summary: RFE recognizing filenames written in script other than latin
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL: http://www.eldesoky.net/linux/konq-ar...
Whiteboard:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-12-11 09:05 UTC by Mohamed Eldesoky
Modified: 2014-03-17 02:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-22 15:40:57 UTC


Attachments (Terms of Use)

Description Mohamed Eldesoky 2002-12-11 09:05:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When viewing directories and listings of filenames which are named in non-latin
characters, it appears as question marks, we found the solution is to add
iocharset=utf8 in the fstab for CD-ROMs and floppies...etc
What if it is included by default in the fstab when installed, and that will
make it easy for all non-latin speakers to see their filenames in their own
languages. It wouldn't harm anyone, since UTF-8 is the default charset in RedHat
8.0 ( and above !!)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Edit the fstab to add the iocharset option
2.Have files named in non-latin characters
3.View them in your favourite file manager
	

Actual Results:  It will help non-expert users alot

Additional info:

Comment 1 Mohamed Eldesoky 2003-07-30 11:47:24 UTC
Isn't it time to revise the issue again ??
It won't harm anyone, but sure it will benefit alot of people.



Comment 2 Mike A. Harris 2003-08-12 04:31:27 UTC
Not sure why I'm on the CC of this bug report as I've no opinion on the matter,
nor would I be involved in it's resolution...

Removing myself...

Comment 3 Mikko Paananen 2003-10-28 15:49:04 UTC
Duplicates: #101987, #107834, #107935.

This problem has been reported least three times during severn beta cycle.

#107834 has alternative fix.

I hope this gets fixed before FC1 release.


Comment 4 Mohamed Eldesoky 2004-01-22 09:32:48 UTC
Any resolutions ??

Comment 5 Bill Nottingham 2004-01-22 15:40:57 UTC
This is changed in the rawhide kernel... it defaults to utf-8.

Comment 6 Bill Nottingham 2004-01-22 15:43:35 UTC
This is changed in the rawhide kernel... it defaults to utf-8.


Note You need to log in before you can comment on or make changes to this bug.