Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79386 - kickstart ondisk fails if specified drive missing
Summary: kickstart ondisk fails if specified drive missing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-11 02:51 UTC by Bill Heiden
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-28 23:17:30 UTC


Attachments (Terms of Use)

Description Bill Heiden 2002-12-11 02:51:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
 Within our facility, we are using a general ks.cfg to install machines.  This 
general ks.cfg uses ondisk within the partition section to create filesystems.  
We create /boot, swap, and / on the primary drive (/dev/sda) and then create 
a /vol2 on /dev/sdb.  If the machine does not have a /dev/sdb, then the 
kickstart installation aborts. It would be great if the installation continued 
and posted a message to one of the log files informing us of the error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Obtain machine with only a single drive
2. Create a ks.cfg that attempts to create a partition/filesystem on a 
secondary non-existent drive.
3. Install using the ks.cfg from step and watch the failure.
	

Additional info:

Comment 1 Brent Fox 2002-12-11 04:28:53 UTC
Changing component to anaconda since this seems related to kickstart and not the
kickstart configuration tool.

Comment 2 Jeremy Katz 2003-01-10 06:52:39 UTC
Will address as time allows -- in general, kickstart assumes that your kickstart
config is appropriate for the machine being installed on.

Comment 3 Jeremy Katz 2003-07-09 05:02:54 UTC
We give a slightly better exception now.  Still need to catch and provide
user-friendly error messages some day, though.


Note You need to log in before you can comment on or make changes to this bug.