Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79367 - ftp client: runique on stops mget from working
Summary: ftp client: runique on stops mget from working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: ftp
Version: 2.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Raszyk
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-10 20:32 UTC by Donnie Cambre
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version: 0.17-23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-22 12:08:38 UTC


Attachments (Terms of Use)

Description Donnie Cambre 2002-12-10 20:32:34 UTC
Description of Problem:

The ftp client does not support the combination of 'runique' and 
'mget' as stated in the man pages.  If runique is turned on during an ftp session, 'mget' fails to get 
anything.  However, 'get' will get the file and rename it with a ".1" (or appropriate 
number).

Version-Release number of selected component (if applicable):
Not sure, 
whatever comes with RedHat 7.1 and 7.3 by default

How Reproducible:
Consistent

Steps 
to Reproduce:
1. FTP to a site with some files to get
2. Turn on runique (ftp> runique)
3. 
Attempt to do an mget (ftp> mget *)
4. No files will be transferred.
5. Turn runique off (ftp> 
runique)
6. Attempt to do an mget (ftp> mget *)
7. All matching files will be transferred
8. 
Turn runique off again
8. Try 'get' and it will get the specified file (ftp> get filename)
9. 
Try 'get' again and it will get the file and rename it with a .1 (ftp> get filename)

Actual 
Results:
Mget does not transfer files with runique on but works fine with runique 
off.

Expected Results:
mget should get all the matching filenames and rename them with a 
suffix if .## (such as .1) when runique is turned on.

Additional Information:
I tried this 
in SuSE Linux 7.3 and it has the same problem.

Comment 1 Thomas Woerner 2004-04-21 15:31:00 UTC
Is this /usr/bin/ftp or /usr/kerberos/bin/ftp?

Comment 2 Donnie Cambre 2004-04-21 15:33:45 UTC
This is /usr/bin/ftp

Comment 3 Thomas Woerner 2004-10-07 14:04:34 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Comment 4 Donnie Cambre 2004-10-14 17:36:04 UTC
Tested with the same result in RedHat Enterprise Linux Advanced Server
2.1.  If runique is enabled, mget does not function.

Comment 5 Thomas Woerner 2004-12-07 11:38:03 UTC
Please have a look at 

http://people.redhat.com/twoerner/SRPMS/2.1AS/ftp-0.17-12.1.3.src.rpm
http://people.redhat.com/twoerner/RPMS/2.1AS/ftp-0.17-12.1.3.i386.rpm

This package should fix the problem.

----
Please remeber that this is a test package, which might be pushed out as an
update package later if the fixes are ok.

Comment 6 Donnie Cambre 2004-12-07 15:05:41 UTC
Tested the linked update (ftp-0.17-12.1.3.i386.rpm) on RHEL AS 2.1 and it fixes
the problem.

Comment 7 Petr Raszyk 2005-08-22 12:02:26 UTC
This bug was fixed by Thomas Woerner <twoerner@redhat.com> on 2004-12-07
It is a patch netkit-ftp-0.17-runique_mget.patch.
This 'bug' does not occure in FEDOR CORE 4.


Note You need to log in before you can comment on or make changes to this bug.