Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79349 - Unable to modify the configuration parameters of an Intel EtherExpress 1000 integrated NIC
Summary: Unable to modify the configuration parameters of an Intel EtherExpress 1000 i...
Keywords:
Status: CLOSED DUPLICATE of bug 76226
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-10 17:11 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-10 17:12:03 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-10 17:11:56 UTC
Description of Problem: Whenever I try to modify the configuration of an EtherExpress 1000 NIC 
via the GUI, I get a bug report and am unable to continue.


Version-Release number of selected 
component (if applicable):


How Reproducible:
If you have a SuperMicro 6012-P6 server 
and one of the Ethernet ports, in my case eth1, is a gigabit port.

Steps to Reproduce:
1. 
Access the Network Configuration applet in either Gnome or KDE
2. Go to the hardware 
section
3. Try to configure the EtherExpress 1000 port

Actual Results:
Bug 
Report

Expected Results:
The ability to modify the configuration of the Ethernet 
port.

Additional Information:
Traceback (innermost last):
  File "/usr/sbin/neat", 
line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 
2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-
packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File 
"/usr/sbin/neat", line 1248, in on_hardwareEditButton_clicked
    
self.showHardwareDialog(type, true)
  File "/usr/sbin/neat", line 1269, in 
showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py", line 
75, in __init__
    self.setup()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/gui/ethernethardware.py", line 135, in setup
    
list.append(modInfo[i]['description'])
KeyError: description

Local variables in 
innermost frame:
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84da978>
list: 
['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA wireless', 'SMC Ultra32 
EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco PCMCIA wireless (alternate)', 'SMC 91c92 
series PCMCIA', 'Aironet 4500 PCI-ISA-i365 wireless', 'Intel EtherExpress/1000', 'PCI NE2000 
clones', 'MiCom-Interlan NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 
ethernet', 'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM MyriNET SBUS', '3Com 
EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 900/7016CI', 'Cabletron E2100', 
'NE1000, NE2000, and compatible', 'Intel EtherExpress Pro 100B', 'Allied Telesis AT1700', 
'Greenwigh GIrBIL IrDA', 'Older DEC 21040, most 21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 
16i/32 EISA', '3Com 3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun BigMac', 
'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel Communications Model 3200', 'Aironet 4500 
PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General Instruments SB1000']
self: 
<netconfpkg.gui.ethernethardware.ethernetHardwareDialog instance at 852cfc0>
i: 
defxx

Comment 1 Harald Hoyer 2002-12-11 11:19:26 UTC

*** This bug has been marked as a duplicate of 76226 ***


Note You need to log in before you can comment on or make changes to this bug.