Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7934 - rp3 insists on 2 /dev/ttyS1s, and doesn't respect params.
Summary: rp3 insists on 2 /dev/ttyS1s, and doesn't respect params.
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rp3
Version: 6.1
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 1999-12-21 18:45 UTC by Harvey Stein
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2000-04-06 20:45:31 UTC

Attachments (Terms of Use)

Description Harvey Stein 1999-12-21 18:45:46 UTC
I tried to use rp3 to dial in to work.  It worked fine when I initially
set it up.  But then I had some hardware trouble.  After fixing it, I
couldn't get 115200 baud to work and moved my modem from /dev/ttyS1 to

When I tried to reconfig rp3, I ran into various weird problems.  First, I
ended up with 3 devices listed - /dev/ttyS0 and *two* entries for
/dev/ttyS1.  Deleting them took them off the screen, but when the device
screen  closed & reopened, the two ttyS1 entries were still there.  When
setting /dev/ttyS1 to the default port, *both* ttyS1 lines had an asterisk
on them.

The next problem was that no matter what I did to the dialup configs, rp3
always configed the device to 115200 baud, even after I set everything to
57200.  It also wouldn't respect the tty set for the entry - it kept using
ttyS1.  I can't remember if it always matched the default tty or just
always ttyS1.  I observed these facts by looking at the pppd command line
with ps.

Finally, I wanted to fix the configs by hand, but the man page didn't say
what files rp3 uses.

Comment 1 Nalin Dahyabhai 2000-01-18 17:00:59 UTC
The rp3 configuration tool uses /etc/wvdial.conf and
/etc/sysconfig/network-scripts/ifcfg-ppp* to do its work.
I've been unable to reproduce the problem here in the
office.  Try shutting down rp3, removing /etc/wvdial.conf
and /etc/sysconfig/network-scripts/ifcfg-ppp*, and see if
things appear more sane.

Comment 2 Nalin Dahyabhai 2000-04-06 20:45:59 UTC
No response for > 2 months, so I assume this was fixed in Raw Hide and 6.2.

Note You need to log in before you can comment on or make changes to this bug.