Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79338 - There is no utf-8 keyboard map for Russian language in kbd
Summary: There is no utf-8 keyboard map for Russian language in kbd
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-10 13:35 UTC by Leonid Kanter
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version: 1.08-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-30 16:07:31 UTC


Attachments (Terms of Use)
Russian UTF-8 keymap (Microsoft windows layout) (deleted)
2002-12-10 13:37 UTC, Leonid Kanter
no flags Details

Description Leonid Kanter 2002-12-10 13:35:28 UTC
Description of Problem: 
 
Default locale for Russian in RHL 8.x is ru_RU.UTF-8, but default keymap "ru" is still 
for 8-bit KOI8-R encoding. As a result, it's impossible to enter cyrillic characters in 
console after fresh install of RHL 8.x. In addition, there is no utf-8 enabled character 
map in current kbd package at all. 
 
Version-Release number of selected component (if applicable): 
 
1.08-1 
 
How Reproducible: 
 
always 
 
Steps to Reproduce: 
1. install Beta2 with Russian language support enabled and set Russian as default 
language during install 
2. make shure that /etc/sysconfig/keytable contain line 'KEYTABLE="ru"' 
3. type "service keyboard start" 
 
Actual Results: 
 
you'll two screens of error messages like this: 
.... 
plus before Agrave ignored 
plus before agrave ignored 
.... 
and if you try to switch to Russian (pressing right control), keyboard output will 
produce latin1 characters  
 
Expected Results: 
 
keyboard output must produce cyrillic characters 
 
Additional Information: 
	  
existing file  /lib/kbd/keymaps/i386/qwerty/ru.kmap.gz must be ranamed to 
ru-koi8-r.kmap.gz or something like this and attached file must be placed there

Comment 1 Leonid Kanter 2002-12-10 13:37:10 UTC
Created attachment 88184 [details]
Russian UTF-8 keymap (Microsoft windows layout)

Comment 2 Aleksey Nogin 2003-01-22 02:59:48 UTC
Also, in both beta3 and beta4 I get a long list of 66 warnings spewed whenever
keytable service is started:

keytable: plus before Ecircumflex ignored
keytable: plus before ecircumflex ignored
keytable: plus before Atilde ignored
keytable: plus before atilde ignored
...
keytable: plus before Agrave ignored
keytable: plus before agrave ignored
keytable: plus before sterling ignored
keytable: plus before threesuperior ignored

and my /etc/sysconfig/keyboard is
KEYBOARDTYPE="pc"
KEYTABLE="ru"

Is it the same problem or a different one?

Comment 3 Leonid Kanter 2003-01-22 13:30:58 UTC
Yes. These error messages are result of 8-bit keymap loading. If you install
attached to this bug keyboard map, everythyng will be Ok (no errors during boot,
russian input works in console).

Comment 4 Eido Inoue 2003-07-14 16:33:48 UTC
non-ASCII input into the console won't be supported on UTF-8 based systems (RHL
8+) until the kernel supports it. See the release notes in the next beta for
more info. Of course, input through X will always be supported.

Comment 5 Eugene Kanter 2003-07-29 13:52:26 UTC
Adrian, 
the primary problem right now is hundreds of lines of error messages during 
keytable load process. I just tried AS 2.9.5 installation. 

Comment 6 Eido Inoue 2003-07-29 14:37:16 UTC
ekanter: I understand, but the problem is out of loadkeys domain; it's a kernel
problem. The kernel doesn't handle UTF-8/Unicode in te console for chars > 127.

The only workaround I know is for Russian users to not use UTF-8 and stick to
KOI8-R until the support can be put in the kernel (which we are trying to do--
it's a big problem).


Comment 7 Leonid Kanter 2003-07-29 15:17:54 UTC
I've already attached Russian keyboard layout for UTF-8. Please just include it
into kbd package in place of koi8 layout. Eugene and Aleksey, please confirm
that   this layout works.

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=88184&action=view

Comment 8 Eugene Kanter 2003-07-29 15:32:46 UTC
Adrian, if yo do not want to include keytable made by Leon please at least have 
us keytable be loaded instead of broken ru keytable in UTF-8 locale.

Comment 9 Aleksey Nogin 2003-07-29 20:38:38 UTC
Yes, the attached map work perfectly for me. Please include it!

Comment 10 Eido Inoue 2003-07-30 16:07:31 UTC
new map included in 1.08-8


Note You need to log in before you can comment on or make changes to this bug.