Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79331 - rpm 4.1 does not seem to support --prefix option
Summary: rpm 4.1 does not seem to support --prefix option
Keywords:
Status: CLOSED DUPLICATE of bug 75057
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-10 09:13 UTC by Rajiv Ganth
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-10 09:13:14 UTC


Attachments (Terms of Use)

Description Rajiv Ganth 2002-12-10 09:13:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have been using Red Hat Linux 7.3 for quiet sometime, and recently upgraded to
8.0.  With this distro, Red Hat is distributing new version of rpm 4.1-x, which
is not supporting some of the rpm commands which I am used to.  First of all,
the documentation CD with the Red Hat 8.0, does not talk about rpm 4.1 but, 4.0.
 There is no place, in the documentation CD, where I could find some info about
latest rpm version with the OS distribution.  

The rpm command is simply ignoring the --prefix option.  
If I say, 

# rpm -Uvh --prefix /usr/local/mine <pkg>.rpm

the package is not installed under /usr/local/mine

It would be great, if you could provide the solution or pointers to the solution.

Thanks in advance.

Version-Release number of selected component (if applicable):
4.1

How reproducible:
Always

Steps to Reproduce:
1.  run command rpm -Uvh --prefix <dir name> <pkg>.rpm


	

Actual Results:  package is not installed under <dir name>

Expected Results:  package should have been installed under the specified
directory <dir name>

Additional info:

Comment 1 Jeff Johnson 2002-12-10 11:59:14 UTC

*** This bug has been marked as a duplicate of 75057 ***


Note You need to log in before you can comment on or make changes to this bug.