Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79326 - rpm "Segmentation fault"
Summary: rpm "Segmentation fault"
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-10 04:56 UTC by Benson Jin
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-10 04:56:31 UTC


Attachments (Terms of Use)

Description Benson Jin 2002-12-10 04:56:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Sympton: rpm exits with error - "Segmentation fault" when used with -i or -U. 
and rpmbuild is the same.

current status: it starts working just now. Hey, I DID have that problem since 
3 days ago. :-( I thought I should regenerate the error message with -vv 
option for your convenience. However, it magically recovered. 8-|

Solution: I don't know yet. It may be caused by ldap auth, since recently I 
have been working on ldap auth for PAM, postfix, courier-imap, and samba. 
maybe some changes I made today, correct the problem? But, but....does rpm 
request any auth during install or update? wired.....

I kept writing instead of quit, because I hope this can help you for future 
troubleshootings. :-D



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set up ldap auth
2.somehow, mess it up
3.run rpm with either -i or -U options
	

Actual Results:  Segmentation fault

Expected Results:  ..... can not expect much, when it is my own fault.... :-(

Additional info:

Comment 1 Jeff Johnson 2002-12-10 12:00:59 UTC
LDAP passwords? Yes, statically linked binaries like
/bin/rpm segfault (or not) depending on whether nscd
is running.


Note You need to log in before you can comment on or make changes to this bug.