Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79318 - change in mv breaks GCC compilation process
Summary: change in mv breaks GCC compilation process
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: coreutils
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-10 02:54 UTC by Igor V. Kovalenko
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-10 02:59:06 UTC


Attachments (Terms of Use)
This patch modifies mv.c so it does not abort with error() from glibc (deleted)
2002-12-10 02:58 UTC, Igor V. Kovalenko
no flags Details | Diff

Description Igor V. Kovalenko 2002-12-10 02:54:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Between stages of GCC compilation there is a file moving directive which uses
predefined file list. In some configurations there are files listed but not
generated by the build process.
coreutils-4.5.3 version of 'mv' stops at the first missing file. This is because
'lstat' call is failing and an 'error' from glibc-2.3.1 apparently aborts the
execution. So not all existing files are moved to their new location.
Previous version of 'mv' (from fileutils- package) just skips missing files
while it moves others.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cd /tmp
2. mkdir mvtestdir
3. touch a b d e g h
4. mv a b c d e f g h mvtestdir
5. ls mvtestdir

Actual Results:  [/tmp]$ mv a b c d e f g h mvtestdir/
/tmp/mv: can't stat source c
[/tmp]$ ls mvtestdir 
a  b


Expected Results:  [/tmp]$ mv a b c d e f g h mvtestdir/
mv: can't stat source c
mv: can't stat source f
[/tmp]$ ls mvtestdir
a  b  d  e  g  h



Additional info:

Comment 1 Igor V. Kovalenko 2002-12-10 02:59:00 UTC
Created attachment 88144 [details]
This patch modifies mv.c so it does not abort with error() from glibc

Comment 2 Tim Waugh 2002-12-10 08:56:38 UTC
This is fixed in coreutils-4.5.3-7.


Note You need to log in before you can comment on or make changes to this bug.