Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79284 - up2date does not resolve packets that are marked in the skiplist
Summary: up2date does not resolve packets that are marked in the skiplist
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date
Version: 2.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-09 16:05 UTC by Steffen Mann
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-15 05:41:40 UTC


Attachments (Terms of Use)

Description Steffen Mann 2002-12-09 16:05:06 UTC
Description of Problem:
up2date glibc-devel ENTER w/o kernel-headers installed

Version-Release number of selected component (if applicable):

up2date2.7.61-7.x.2
kernel-headers 2.4.9e.i3
gcc2.96


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

to come across this we did up2date -f kernel-headers and then 
up2date gcc 

prior to this glibc-devel came back with the error message that and
kernel-headers are required and it can not resolve packet interdependencies,
which it shouln't have, or it should have said that the *kernel is marked in the
skiplist and it can not resolve interdependencies because of this.

Expected Results:

resolve dependencies even kernel-headers are in skiplist, they need to be installed!

Additional Information:

Comment 1 Adrian Likins 2003-01-15 05:41:40 UTC
Things on the skiplist are not installed. Even when they are deps (especially
when they are deps...)

That said, the error messages should indicate why the package wasn't
available. I belive this error reporting is more verbose in current versions.




Note You need to log in before you can comment on or make changes to this bug.