Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79276 - beta 2 serial mouse interaction issues
Summary: beta 2 serial mouse interaction issues
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-09 14:15 UTC by R P Herrold
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:17 UTC


Attachments (Terms of Use)

Description R P Herrold 2002-12-09 14:15:35 UTC
Follow on bug under beta 2 of Gingin
 https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=78809

For some reason, the serial mouse is not being pulled out of the config file,
and gpm is being killed.

I restarted gpm, and moved the mouse to confirm its presence in console mode
before running redhat-config-xfree86

Then:

* ddcprobe returned bogus values:
ID:   GSM427d
Name: None
HorizSync: -268377405--268376112
VertSync:  -268376112--268370092

Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 1091, in ?
    xconfig = generate_xconfig(hardware_state)
  File "/usr/share/redhat-config-xfree86/xconf.py", line 855, in
generate_xconfig
    get_option(corepointer, "Device").val = "/dev/" + mouse.getDevice()
TypeError: cannot concatenate 'str' and 'NoneType' objects


checking /dev:

Subject: mouse-there

lrwxrwxrwx    1 root     root            5 Dec  8 21:55 /dev/mouse -> ttyS0

and it killed the mouse as well.

bizarre

Comment 1 Brent Fox 2002-12-23 07:15:17 UTC

*** This bug has been marked as a duplicate of 80115 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.