Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79271 - bad PS font substitutions
Summary: bad PS font substitutions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libgnomeprint22
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
: 107862 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-12-09 12:56 UTC by Tim Waugh
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-03 15:10:23 UTC


Attachments (Terms of Use)

Description Tim Waugh 2002-12-09 12:56:24 UTC
Description of Problem:
Sorry this is so vague, but: when printing an (HTML format) email, sometimes the
font is substituted for a ridiculous one.

Version-Release number of selected component (if applicable):
evolution-1.2.0-3

For instance, an email containing <font face="Verdana, Arial, Helvetica"
color="003399" size="2"> generated PS output like this:

[...]
%%DocumentSuppliedResources: procset gnome-print-procs-0.35
%%+ font GnomeUni-AmericanIndian-Regular
%%+ font GnomeUni-Helvetica
%%+ font GnomeUni-Helvetica-Bold
%%EndComments
[...]

(AmericanIndian is a symbol font I happen to have installed.)

Comment 1 Jeremy Katz 2002-12-09 17:30:59 UTC
This is all gnome-print...

Comment 2 Owen Taylor 2003-01-14 17:42:01 UTC
Can you re-test with gnome-print-0.37?

Comment 3 Tim Waugh 2003-01-16 13:47:12 UTC
It's different behaviour, certainly.  Rather than picking 'AmericanIndian' it
now picks '4MyLover'.

It happened to be legible, but it's not by any means appropriate!

Relevant PS snippet again:

%%DocumentSuppliedResources: procset gnome-print-procs-0.37
%%+ font GnomeUni-4-my-lover-Regular
%%+ font GnomeUni-Helvetica
%%+ font GnomeUni-Helvetica-Bold
%%EndComments



Comment 4 Tim Waugh 2003-02-06 15:17:31 UTC
gedit used to do the same thing for any text, but now seems to be fixed.

But evolution still does the same thing.

Comment 5 Tim Waugh 2003-06-04 08:58:44 UTC
State of rawhide:

gedit is still behaving itself, but now evolution is worse than before: now the
message doesn't have to be HTML.  A plain text email comes out in the wrong font.

$ rpm -q evolution; rpm -q --whatprovides $(rpm -q --requires evolution | grep
gnomeprint)
evolution-1.3.92-1
libgnomeprint22-2.2.1.1-3
libgnomeprintui22-2.2.1.1-1

Comment 6 Thomas Zehetbauer 2003-06-27 00:21:49 UTC
Upgrading to libgnomeprint22-2.2.1.2-2 from rawhide solved this problem for me
(RedHat9/Ximian evolution-1.4.0-0.ximian.6.6)

Comment 7 Tim Waugh 2003-06-27 08:33:52 UTC
What I see with that version is mostly the right font, with the exception of the
font used for page numbers at the bottom of the page.  I am using
evolution-1.4.0-2 now, and libgnomeprint22-2.2.1.2-2.

Comment 8 Owen Taylor 2003-08-29 13:44:54 UTC
Problem is that evolution is asking for "Helvetica", which isn't
there, then gnome-print falls back to "Helvetica" which isn't there,
so gnome-print falls back to whatever is alphabetically first.

Filed gnome-print bug as:

http://bugzilla.gnome.org/show_bug.cgi?id=120954

Evolution bug as:

http://bugzilla.ximian.com/show_bug.cgi?id=48013

With a patch in libgnomeprint, there is no real reason to fix it
in our Evolution packages before it is fixed upstream.

* Thu Aug 28 2003 Owen Taylor <otaylor@redhat.com> 2.3.1-2
- Make the fallback font "Sans Regular", not "Helvetica". Helvetica
  was ending up picking the alphabetically first font on the system.
  (#79271. Tim Waugh)


Comment 9 Tim Waugh 2003-12-23 14:27:22 UTC
This is happening again.

Comment 10 Tim Waugh 2003-12-23 14:32:00 UTC
*** Bug 107862 has been marked as a duplicate of this bug. ***

Comment 11 Tim Waugh 2003-12-23 14:32:59 UTC
It broke between 2.3.1-2 and 2.4.0-1.

Comment 12 Tim Waugh 2003-12-23 14:41:16 UTC
Hmm, I'm wrong; 2.3.1-2 also fails.  Red Hat Linux 9 worked though,
I'm pretty sure.

Comment 13 Tim Waugh 2004-01-14 23:00:42 UTC
libgnomeprint22-2.4.2-1.1 fixes the problem -- will it be available as
a Fedora Core 1 update?

Comment 14 Dan Tucny 2004-04-12 18:29:19 UTC
I can confirm, libgnomeprint22-2.4.2-1.1 does indeed fix this
problem... Is it going to be released?

Comment 15 Owen Taylor 2004-08-03 15:10:23 UTC
Not going to do a FC1 update at this point.


Note You need to log in before you can comment on or make changes to this bug.