Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79252 - MySQL DBD triggers undefined symbol
Summary: MySQL DBD triggers undefined symbol
Keywords:
Status: CLOSED DUPLICATE of bug 80562
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl-DBD-MySQL
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-08 20:47 UTC by Wade Minter
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:17 UTC


Attachments (Terms of Use)

Description Wade Minter 2002-12-08 20:47:30 UTC
Description of Problem:

Did an upgrade from Psyche-->GinGin1-->GinGin2.  Attempted to run a Perl
application with a database call, and got:

/usr/bin/perl: relocation error:
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/DBD/mysql/mysql.so:
undefined symbol: mysql_init

The following reduced testcase generates the bug, too.

#######
use DBI;

$dbh = DBI->connect("DBI:mysql:mysql","root","password");
$query = "SELECT * FROM users";
my $sth=$dbh->prepare($query);
$sth->execute;
$sth->finish;
#####


MySQL packages installed:
[minter@localhost minter]$ rpm -qa | grep -i mysql
perl-DBD-MySQL-2.1017-4
MySQL-python-0.9.1-4
mysql-3.23.52-5
mysql-server-3.23.52-5

perl-DBI-1.30-2

Comment 1 Chip Turner 2003-01-07 04:27:35 UTC

*** This bug has been marked as a duplicate of 80562 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.