Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79246 - Password Aging does not reflect correct settings
Summary: Password Aging does not reflect correct settings
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-08 15:14 UTC by Jeff Spellman
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-17 16:51:49 UTC


Attachments (Terms of Use)

Description Jeff Spellman 2002-12-08 15:14:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
I noticed this on the 7.3 and 8.0 Releases of the OS. I can go to properties 
for a new user (uid 500 on up) and setup a password aging requirement. After I 
exit, settings are correctly set in the /etc/shadow file. However, when I 
return to the same place in the configuration program, password aging for the 
same user will be unchecked, and 0's in the 'time' boxes. If one was to 
actually click 'OK' at that point, /etc/shadow would reflect that state.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add new user
2. Select that user, go to properties
3. Go to Password Info tab
4. Check the 'Enable password expiration' checkbox
5. I set the four fields (top to bottom) to 0, 7, 7, 30
6. Click OK, then exit
7. Re-enter program, go look at password aging settings fot same user.
 
	

Additional info:

I don't know if this is the desired behavior. It did not act this way in 7.2
I will submit as 'Normal' only because it was "okay" in 7.2
This was verified on a fresh install of 7.3 (just in case I broke it)

Comment 1 Brent Fox 2002-12-17 22:58:00 UTC
Should be fixed in redhat-config-users-1.1.1-5.  Thanks for your report.  QA,
please verify.

Comment 2 Peter van Egdom 2003-03-15 11:13:08 UTC
Reproduced steps as stated by Jeff. Verified fixed.

Seems to work correctly on Phoebe 8.0.94 with "redhat-config-users-1.1.5-6".

Comment 3 Brent Fox 2003-03-17 16:51:49 UTC
Thanks for the testing.  Resolving as Rawhide.  Feel free to resolve as Rawhide
yourself if you've verified that the fix works.  


Note You need to log in before you can comment on or make changes to this bug.