Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79244 - isdnctrl chargehup <device> stays always on
Summary: isdnctrl chargehup <device> stays always on
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: isdn4k-utils
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-08 14:43 UTC by Peter Bieringer
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-14 19:31:41 UTC


Attachments (Terms of Use)

Description Peter Bieringer 2002-12-08 14:43:13 UTC
Description of problem:
chargehup cannot be disabled

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. # isdnctrl chargehup isdn0
Charge-Hangup for isdn0 is on
2. # isdnctrl chargehup isdn0 off
Charge-Hangup for isdn0 is off
3. # isdnctrl chargehup isdn0
Charge-Hangup for isdn0 is on

Actual Results:  Cannot be switched to "off"

Expected Results:  Switching to "off" will work

Additional info:

# uname -r
2.4.18-18.7.xcustom3 (nothing in ISDN section was changed)

(also seen running 2.4.18-17.7.x)

# rpm -q --queryformat "%{name}-%{version}-%{release}\n" isdn4k-utils
isdn4k-utils-3.1-53

Seen on 2 systems:

Elsa Quickstep 1000 ISA
# more /etc/sysconfig/isdncard
MODULE="hisax"
RESOURCES="type=7 protocol=2 irq=5 io=0x160"

Elsa Quickstep 1000 PCI
# more /etc/sysconfig/isdncard
MODULE="hisax"
RESOURCES="type=18 protocol=2"

Comment 1 Ngo Than 2002-12-08 20:12:03 UTC
It's fixed in isdn4k-utils-3.1-58, which is in 8.0 RHL.

Comment 2 Peter Bieringer 2003-10-05 14:06:25 UTC
Sorry for late reply, no heavier usage and I found also another strange bug.

I have here 3 isdn links configured.

Hangup-Timeout is resetted to 3 seconds after link was terminated by
hanguptimeout. Set it to e.g. 180 seconds again won't help.

BTW: pls. provide an updated package for RHL 7.3

Comment 3 Peter Bieringer 2004-05-01 12:46:19 UTC
Bug exists still in FC1

# isdnctrl huptimeout isdn1 60
# isdnctrl list isdn1 |grep Hangup-Timeout
let kernel hangup
# isdnctrl dial isdn1
Dialing of isdn1 triggered
# isdnctrl list isdn1 |grep Hangup-Timeout
Hangup-Timeout:         3


# rpm -q isdn4k-utils
isdn4k-utils-3.2-5.p1

# uname -a
Linux host 2.4.22-1.2188.nptl #1 Wed Apr 21 20:36:05 EDT 2004 i686
i686 i386 GNU/Linux

Comment 4 Peter Bieringer 2004-05-01 12:47:51 UTC
Ooops. forgot a missing output line:

# isdnctrl huptimeout isdn1 60
# isdnctrl list isdn1 |grep Hangup-Timeout
Hangup-Timeout:         60
let kernel hangup
# isdnctrl dial isdn1
Dialing of isdn1 triggered
# isdnctrl list isdn1 |grep Hangup-Timeout
Hangup-Timeout:         3

Comment 5 Peter Bieringer 2004-12-26 20:50:18 UTC
The problems still occur, looks like there is still something broken.

Dist: FC3
kernel: 2.6.9-1.681_FC3
isdn4k-utils: 3.2-18.p1.1

Outdialing box:

# isdnctrl list isdn0

Current setup of interface 'isdn0':

EAZ/MSN:                *****
Phone number(s):
  Outgoing:             *****
  Incoming:             *****
Dial mode:              manual
Secure:                 on
Callback:               in
Reject before Callback: on
Callback-delay:         1
Dialmax:                1
Hangup-Timeout:         180
Incoming-Hangup:        on
ChargeHangup:           on
Charge-Units:           0
Charge-Interval:        60
Layer-2-Protocol:       hdlc
Layer-3-Protocol:       trans
Encapsulation:          ip
Slave Interface:        None
Slave delay:            10
Master Interface:       None
Pre-Bound to:           Nothing
PPP-Bound to:           Nothing

Manual dial triggered:

Dec 26 21:38:09 gate kernel: isdn0: dialing 1 *****...
Dec 26 21:38:11 gate kernel: isdn_net: isdn0 connected
Dec 26 21:39:10 gate kernel: isdn_net: local hangup isdn0
Dec 26 21:39:10 gate kernel: isdn0: Chargesum is 0

Hangup is after 60 seconds, not after 180 as expected.
Also the settings have changed automagically:

# isdnctrl list isdn0

Current setup of interface 'isdn0':

EAZ/MSN:                *****
Phone number(s):
  Outgoing:             *****
  Incoming:             *****
Dial mode:              manual
Secure:                 on
Callback:               in
Reject before Callback: on
Callback-delay:         1
Dialmax:                1
Hangup-Timeout:         3      <-!!!
Incoming-Hangup:        on
ChargeHangup:           on
Charge-Units:           0
Charge-Interval:        60
Layer-2-Protocol:       hdlc
Layer-3-Protocol:       trans
Encapsulation:          ip
Slave Interface:        None
Slave delay:            10
Master Interface:       None
Pre-Bound to:           Nothing
PPP-Bound to:           Nothing


chargehup still cannot be switched off:

# isdnctrl chargehup isdn0
Charge-Hangup for isdn0 is on
# isdnctrl chargehup isdn0 off
Charge-Hangup for isdn0 is off
# isdnctrl chargehup isdn0
Charge-Hangup for isdn0 is on



Comment 6 Ngo Than 2006-05-02 10:56:56 UTC
Peter, could you verify if it's fixed in rawhide? if not, please reassign it 
to fc5. Thanks

Comment 7 Peter Bieringer 2006-05-02 11:02:52 UTC
Still not fixed.

# isdnctrl list isdn0

Current setup of interface 'isdn0':

EAZ/MSN:                ******
Phone number(s):
  Outgoing:             ******
  Incoming:             ******
Dial mode:              manual
Secure:                 on
Callback:               in
Reject before Callback: on
Callback-delay:         1
Dialmax:                1
Hangup-Timeout:         180
Incoming-Hangup:        on
ChargeHangup:           on
Charge-Units:           0
Charge-Interval:        60
Layer-2-Protocol:       hdlc
Layer-3-Protocol:       trans
Encapsulation:          ip
Slave Interface:        None
Slave delay:            10
Master Interface:       None
Pre-Bound to:           Nothing
PPP-Bound to:           Nothing

# isdnctrl chargehup isdn0 off
Charge-Hangup for isdn0 is off

# isdnctrl chargehup isdn0
Charge-Hangup for isdn0 is on

# rpm -q isdn4k-utils
isdn4k-utils-3.2-40

# cat /etc/fedora-release
Fedora Core release 5 (Bordeaux)


Comment 8 Ngo Than 2006-05-02 12:42:51 UTC
Peter, i cannot reproduce this problem on RHEL4 with isdn4k-utils-3.2-18.p1.5 
and kernel-2.6.9-6.37.EL. It works for me.

# isdnctrl list isdn0

EAZ/MSN:                0
Phone number(s):
  Outgoing:             010700192020
  Incoming:             123456789
Dial mode:              manual
Secure:                 on
Callback:               in
Reject before Callback: off
Callback-delay:         3
Dialmax:                1
Hangup-Timeout:         600
Incoming-Hangup:        on
ChargeHangup:           on
Charge-Units:           0
Charge-Interval:        0
Layer-2-Protocol:       hdlc
Layer-3-Protocol:       trans
Encapsulation:          ip
Slave Interface:        None
Slave delay:            10
Master Interface:       None
Pre-Bound to:           Nothing
PPP-Bound to:           Nothing

# isdnctrl chargehup isdn0 off
Charge-Hangup for isdn0 is off

# isdnctrl chargehup isdn0
Charge-Hangup for isdn0 is off

ATM i don't have any idea why it does not work for you. My ISDN Card is
AVM PCI (Fritz!PCI). Any idea how i can reproduce this bug? Thanks




Comment 9 Peter Bieringer 2006-05-02 13:13:21 UTC
Hmm, I can reproduce this on

RHEL4 running kernel 2.6.9-34.EL with
01:09.0 Network controller: AVM Audiovisuelles MKTG & Computer System GmbH A1
ISDN [Fritz] (rev 02)

and 
RHEL4 running kernel 2.6.9-22.0.2.EL with
00:0c.0 Network controller: Elsa AG QuickStep 1000 (rev 01)

Config is like that:

DEVICE="isdn0"
#ONBOOT="yes"
ONBOOT="no"
BOOTPROTO="none"
IPADDR="172.16.253.2"
GATEWAY="172.16.253.1"
NETMASK="255.255.255.252"
DEFROUTE="no"
MSN="*****"
PHONE_OUT="****"
PHONE_IN="*****"
ENCAP="ip"
DIALMODE="manual"
L2_PROT="hdlc"
L3_PROT="trans"
SECURE="on"
HUPTIMEOUT="180"
CHARGEHUP="off"
CHARGEINT="600"
IHUP="on"
DIALMAX="1"
CALLBACK="out"
CBDELAY="1"
CBHUB="on"
# Slave device
BUNDLING="no"                           # Channel bundling [yes|no]
SLAVE_DEVICE=""
SLAVE_MSN=""
SLAVE_PHONE_OUT=""
SLAVE_PHONE_IN=""
SLAVE_HUPTIMEOUT=""
SLAVE_CHARGEHUP=""
SLAVE_CHARGEINT=""
SLAVE_IHUP=""
SLAVE_DIALMAX=""
SLAVE_CALLBACK=""
SLAVE_CBDELAY=""
SLAVE_DIALMODE=""
# PPP section
USER=""                         # PPP username
AUTH=""                         # PPP authentication "-pap +chap"
VJ=""                           # VJ compression [on|off]
VJCOMP=""                       # VJ compression [on|off]
AC=""
PC=""
BSDCOMP=""
MRU=""
MTU=""
CBCP=""                         # Callback protocol [on]
CCP=""                          # CCP
ISDN_HOSTNAME=""                # Hostname for ISDN
PPPOPTIONS=""
DNS1=""
DNS2=""
DEBUG=""

Playing around I found the next funny issue:

# isdnctrl chargeint isdn2 0
Charge Interval for isdn2 is 0 sec.

# isdnctrl chargeint isdn2
Charge Interval for isdn2 is 600 sec.

Happen on all 3 systems, also on the
FC5 running 2.6.16-1.2096_FC5 with 
00:0a.0 Network controller: Elsa AG QuickStep 1000 (rev 01)

Looks like values below 11 are silently accepted, but not set.

But even funny, if config contains CHARGEINT="0", initially it can be set to 0.
Same happen with CHARGEHUP="off".

Digging further I found why you get a different result.

You have chargeint=0, so configure chargeint now like:
# isdnctrl chargeint isdn0 60

Now try to disable chargehup...won't work anymore.
And you can't set chargeint to 0 again also.




Comment 10 petrosyan 2008-02-14 05:40:39 UTC
Fedora Core 5 is not maintained anymore.

Can you reproduce this bug in Fedora 8?

Comment 11 Peter Bieringer 2008-02-14 19:31:41 UTC
Not really anymore, not using this kind of out-of-band access currently. You can
close it for now, I will reopen it if I ever setup such link again and found the
same issue.


Note You need to log in before you can comment on or make changes to this bug.