Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79243 - usage of deprecated rpm commands in python distutils
Summary: usage of deprecated rpm commands in python distutils
Keywords:
Status: CLOSED DUPLICATE of bug 75304
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python2
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-08 14:32 UTC by Joachim Metz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-08 14:32:56 UTC


Attachments (Terms of Use)

Description Joachim Metz 2002-12-08 14:32:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
the file /usr/lib/python2.2/distutils/command/bdist_rpm.py still uses the 'rpm'
command (-ba, -bb, etc) to build RPMS. This should be rpmbuild in RedHat 8.0 (to
my knowledge).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to build numpy (http://sourceforge.net/projects/numpy). After unpacking:
python setup.py bdist_rpm --release="i386".

Actual Results:  1. It will fail attempting to run "rpm -ba ..."

Expected Results:  It should have run "rpmbuild -ba ..."

Additional info:

Changing 'rpm' to 'rpmbuild' in
/usr/lib/python2.2/distutils/command/bdist_rpm.py at line 284 solves the problem.

Comment 1 Mihai Ibanescu 2002-12-08 17:42:22 UTC

*** This bug has been marked as a duplicate of 75304 ***


Note You need to log in before you can comment on or make changes to this bug.