Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79215 - Incorrect sound card driver for IBM Thinkpad T23
Summary: Incorrect sound card driver for IBM Thinkpad T23
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
high
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-07 17:40 UTC by tirant
Modified: 2007-03-27 03:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-27 17:34:08 UTC


Attachments (Terms of Use)

Description tirant 2002-12-07 17:40:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-AR; rv:1.0.1) Gecko/20021003

Description of problem:
IBM Thinkpad T23's soundcard doesn't work with RedHat 8.0 Kudzu detects it
correctly, but the i810_audio module doesn't work.It may work with ALSA sound
drivers. 
It also seems to make xmms hang, because i get a segmentation fault everytime i
try to run it.

cat /proc/pci
PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: Intel Corp. 82830 830 Chipset Host Bridge (rev 4).
      Prefetchable 32 bit memory at 0xd0000000 [0xdfffffff].
  Bus  0, device   1, function  0:
    PCI bridge: Intel Corp. 82830 830 Chipset AGP Bridge (rev 4).
      Master Capable.  Latency=96.  Min Gnt=12.
  Bus  0, device  29, function  0:
    USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 2).
      IRQ 11.
      I/O at 0x1800 [0x181f].
  Bus  0, device  29, function  1:
    USB Controller: Intel Corp. 82801CA/CAM USB (Hub #2) (rev 2).
      IRQ 11.
      I/O at 0x1820 [0x183f].
  Bus  0, device  29, function  2:
    USB Controller: Intel Corp. 82801CA/CAM USB (Hub #3) (rev 2).
      IRQ 11.
      I/O at 0x1840 [0x185f].
  Bus  0, device  30, function  0:
    PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 66).
      Master Capable.  No bursts.  Min Gnt=4.
  Bus  0, device  31, function  0:
    ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 2).
  Bus  0, device  31, function  1:
    IDE interface: Intel Corp. 82801CAM IDE U100 (rev 2).
      IRQ 11.
      I/O at 0x1860 [0x186f].
      Non-prefetchable 32 bit memory at 0x10000000 [0x100003ff].
  Bus  0, device  31, function  3:
    SMBus: Intel Corp. 82801CA/CAM SMBus (rev 2).
      IRQ 11.
      I/O at 0x1880 [0x189f].
  Bus  0, device  31, function  5:
    Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio (rev 2).
      IRQ 11.
      I/O at 0x1c00 [0x1cff].
      I/O at 0x18c0 [0x18ff].
  Bus  1, device   0, function  0:
    VGA compatible controller: PCI device 5333:8c2e (S3 Inc.) (rev 5).
      IRQ 11.
      Master Capable.  Latency=64.  Min Gnt=4.Max Lat=255.
      Non-prefetchable 32 bit memory at 0xc0100000 [0xc017ffff].
      Prefetchable 32 bit memory at 0xe8000000 [0xebffffff].
      Prefetchable 32 bit memory at 0xe4000000 [0xe7ffffff].
      Prefetchable 32 bit memory at 0xe0000000 [0xe1ffffff].
  Bus  2, device   0, function  0:
    CardBus bridge: Texas Instruments PCI1420 (rev 0).
      IRQ 11.
      Master Capable.  Latency=168.  Min Gnt=192.Max Lat=5.
      Non-prefetchable 32 bit memory at 0x50000000 [0x50000fff].
  Bus  2, device   0, function  1:
    CardBus bridge: Texas Instruments PCI1420 (#2) (rev 0).
      IRQ 11.
      Master Capable.  Latency=168.  Min Gnt=192.Max Lat=5.
      Non-prefetchable 32 bit memory at 0x51000000 [0x51000fff].
  Bus  2, device   2, function  0:
    Communication controller: Lucent Microelectronics WinModem 56k (rev 1).
      IRQ 11.
      Master Capable.  No bursts.  Min Gnt=252.Max Lat=14.
      Non-prefetchable 32 bit memory at 0xc0201000 [0xc02010ff].
      I/O at 0x6440 [0x6447].
      I/O at 0x6000 [0x60ff].
  Bus  2, device   8, function  0:
    Ethernet controller: Intel Corp. 82801CAM (ICH3) Chipset Ethernet Controller
(rev 66).
      IRQ 11.
      Master Capable.  Latency=66.  Min Gnt=8.Max Lat=56.
      Non-prefetchable 32 bit memory at 0xc0200000 [0xc0200fff].
      I/O at 0x6400 [0x643f].

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat 8.0

Actual Results:  Sound doesn't work

Expected Results:  Sound should work

Additional info:

Hardware: IBM Thinkpad T23 2647.

Comment 1 Arjan van de Ven 2002-12-09 18:00:38 UTC
have you tried the latest erratum kernel ?

Comment 2 tirant 2002-12-09 22:39:14 UTC
Yes, i have updated everything with redhat's updating tool. 
BTW, Xmms problem seems to be a known bug related to arts notinstalled.

Comment 3 Alan Cox 2002-12-16 05:12:31 UTC
Please attach a dmesg from after trying to play audio, and the output of lspci -vxx



Note You need to log in before you can comment on or make changes to this bug.