Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79211 - Fail to rebuild src.rpm of freetype 2.1.2
Summary: Fail to rebuild src.rpm of freetype 2.1.2
Keywords:
Status: CLOSED DUPLICATE of bug 74415
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: freetype
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-07 16:08 UTC by Dennis Björklund
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:17 UTC


Attachments (Terms of Use)

Description Dennis Björklund 2002-12-07 16:08:48 UTC
Description of Problem:
Source rpm of freetype can not be rebuilt. I have a new installed
redhat 8 system and tried to rebuild freetype but it failed in
the end while collecting files to package. It's missing the
file libttf.so in package freetype-devel. The version in raw hide and the
version in redhat 8 is the same.


Version-Release number of selected component (if applicable):
2.1.2

Steps to Reproduce:
1. rpmbuild --rebuild freetype-2.1.2-7.src.rpm

Actual Results:
This is the last lines I got when trying to rebuild the src.rpm:

Finding  Requires: /usr/lib/rpm/find-requires
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <=
3.0.4-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Requires: freetype = 2.1.2-7 libX11.so.6 libc.so.6 libc.so.6(GLIBC_2.0)
libfreetype.so.6 libm.so.6 libm.so.6(GLIBC_2.0)
Processing files: freetype-devel-2.1.2-7
error: File not found:
/home/dennis/compile/rpm/tmp/freetype-2.1.2-root/usr/lib/libttf.so
Requires: freetype = 2.1.2-7


RPM build errors:
    File not found by glob:
/home/dennis/compile/rpm/tmp/freetype-2.1.2-root/usr/lib/libttf.so.*
    File not found:
/home/dennis/compile/rpm/tmp/freetype-2.1.2-root/usr/lib/libttf.so

Comment 1 Owen Taylor 2003-01-03 20:31:24 UTC

*** This bug has been marked as a duplicate of 74415 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.