Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79201 - No APM support compiled into kernel?
Summary: No APM support compiled into kernel?
Keywords:
Status: CLOSED DUPLICATE of bug 82123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-07 03:07 UTC by Wade Minter
Modified: 2013-07-03 02:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:17 UTC


Attachments (Terms of Use)

Description Wade Minter 2002-12-07 03:07:22 UTC
Description of Problem:

Performed an upgrade from 8.0/Psyche to GinGin/beta1 on my laptop.

Upon booting into KDE, the battery monitor indicator shows a battery with an X
through it.  So I went to a console and ran "apm" to see what the power
management reported, and it said:

[root@localhost root]# apm
No APM support in kernel

Is this an oversight, or is there a new way of handling power management in GinGin?

[root@localhost root]# rpm -q apmd
apmd-3.0.2-12

Comment 1 Wade Minter 2002-12-08 20:38:20 UTC
This problem appears to be fixed in GinGin2.

Comment 2 Wade Minter 2003-01-01 22:51:33 UTC
Spoke too soon, it's back in Phoebe1.  Upgraded from GinGin2.

Comment 3 Wade Minter 2003-01-03 13:23:46 UTC
It appears ACPI is the culprit - I added "acpi=off" to my kernel boot params,
and the APM monitor works fine now.

Comment 4 Jeff Garzik 2003-01-17 21:09:39 UTC

*** This bug has been marked as a duplicate of 82123 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.