Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7918 - linuxconf refuses to start, "segmentation error," dumps core
Summary: linuxconf refuses to start, "segmentation error," dumps core
Keywords:
Status: CLOSED DUPLICATE of bug 7874
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-20 23:40 UTC by William Lutts
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-10 22:17:13 UTC


Attachments (Terms of Use)

Description William Lutts 1999-12-20 23:40:32 UTC
With 6.1 fully upgraded and the latest linuxconf posted on Dec. 15, 1999,
linuxconf worked fine for two days, then crashed in the middle of
configuring Samba. Henceforth it refused to start at all from the menu, or
from an X-terminal, or from a text terminal. Error message generated said
only "segmentation error (core dump)" Command "$file core" suggested that
it was a signal 11, memory problem. The rest of Redhat worked fine. So did
Win '98 when I rebooted. Physical memory problem unlikely. I tried many
things and RH tech support scratched their heads too. Then after taking a
break I realized that if linuxconf went terminally insane while configuring
Samba, it might make sense to look at the file /etc/smb.conf. Sure enough!
The Samba configuration file smb.conf was full of non-printing garbage
characters, in such a state as to justify the description "totally gorfed."

Solution: In the Samba section of /usr/doc there is an "examples"
directory. In that directory is a copy of the original Samba configuration
default file. Delete or rename the gorfed smb.conf in /etc and copy the
original Samba configuration file from the Samba "examples" directory into
/etc, taking care to rename it to smb.conf. Now linuxconf works fine once
more. Why it gorfed the smb.conf file in the first place I don't know. If
it will do it again, I don't know that either. Hope not.

Comment 1 jmorton 2000-01-10 14:05:59 UTC
I encountered the exact problem after configuring Samba.

Comment 2 Nalin Dahyabhai 2000-01-10 22:17:59 UTC
*** This bug has been marked as a duplicate of 7874 ***


Note You need to log in before you can comment on or make changes to this bug.