Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79172 - man pages no longer sized to fit terminal ...
Summary: man pages no longer sized to fit terminal ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-06 18:29 UTC by Bill Crawford
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-29 15:27:56 UTC


Attachments (Terms of Use)

Description Bill Crawford 2002-12-06 18:29:33 UTC
Description of Problem:
In previous versions, the man page would be displayed with an appropriate number
of columns to suit the size of the terminal (I'm using an xterm set at 96x32
using X resources, but the same thing happens if I resize manually).


Version-Release number of selected component (if applicable):
[bill@fraser man]$ rpm -q man groff
man-1.5j-11
groff-1.18-6

How Reproducible:
View any man page in a xterm at other than 80 columns :)

Expected Results:
For the man page to be displayed at an appropriate width for the xterm.

Additional Information:
It appears that the command issued by man is trying to set the width as in
previous versions, but with the current version of groff it isn't working.  I
think this may be due to changes in an-old.tmac, but not absolutely sure. 
However altering the command to issue ".nr LL 96n" instead of ".ll 8.6i" works
fine ...

Result of "ps auxww" (trimmed):

bill      1139  0.0  0.2  3400  748 pts/6    S    18:27   0:00 man cvs
bill      1142  0.0  0.3  3808  956 pts/6    S    18:27   0:00 sh -c (cd
/usr/share/man && (echo ".ll 8.6i"; echo ".pl 1100i"; /bin/gunzip -c
'/usr/share/man/man1/cvs.1.gz'; echo; echo ".pl \n(nlu+10") | /usr/bin/gtbl |
/usr/bin/nroff -c -mandoc | less -is)
bill      1143  0.0  0.3  3812 1008 pts/6    S    18:27   0:00 sh -c (cd
/usr/share/man && (echo ".ll 8.6i"; echo ".pl 1100i"; /bin/gunzip -c
'/usr/share/man/man1/cvs.1.gz'; echo; echo ".pl \n(nlu+10") | /usr/bin/gtbl |
/usr/bin/nroff -c -mandoc | less -is)
bill      1146  0.0  0.4  3824 1076 pts/6    S    18:27   0:00 /bin/sh
/usr/bin/nroff -c -mandoc
bill      1147  0.0  0.2  1704  612 pts/6    S    18:27   0:00 less -is
bill      1151  0.0  0.3  4084  988 pts/6    S    18:27   0:00 groff -mtty-char
-Tutf8 -P-c -mandoc
bill      1153  1.7  0.7  4900 1800 pts/6    S    18:27   0:00 grotty -c

If I rerun the same commands but change the echo command to ".nr LL 96n" it
works sort of OK (but the lines actually still wrap :() ,.... and amusingly if I
run man in a 80-column xterm I am finding lines wrapping occasionally(!) so
something is broken anyway ...

Comment 1 Derek Martin 2002-12-18 07:23:08 UTC
Yeah, I'm seeing the same broken behavior...

Comment 2 Eido Inoue 2003-02-07 20:17:32 UTC
*** Bug 80893 has been marked as a duplicate of this bug. ***

Comment 3 Florian La Roche 2003-02-08 01:15:48 UTC
The debian changelog also documents that setting the line length
changed for groff-1.18 and that newer man_db releases do this correctly now.
Look in man_db 2.4.1 for "-rLL=" and "-rLT=" settings for newer groff
releases.

greetings,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.