Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79159 - Exception occurred when try to configure a network card
Summary: Exception occurred when try to configure a network card
Keywords:
Status: CLOSED DUPLICATE of bug 76226
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-06 16:13 UTC by gelty
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-06 16:14:04 UTC


Attachments (Terms of Use)

Description gelty 2002-12-06 16:13:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem: Crash of application


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start redhat-control-network (italian version) by command line
2. Clic on "Configure" when select the network interface
3. Select the "Hardware" tab
4. Select the network card (in this case a RealTec RTL-8139, SMC EZ Card)
5. Clic on "Modify"
	

Actual Results:  
Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1248, in on_hardwareEditButton_clicked
    self.showHardwareDialog(type, true)
  File "/usr/sbin/neat", line 1269, in showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File
"/usr/bin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 75, in __init__
    self.setup()
  File
"/usr/bin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 135, in setup
    list.append(modInfo[i]['description'])
KeyError: description


Expected Results:  A network card configuration window

Additional info:

Comment 1 Harald Hoyer 2002-12-09 10:10:12 UTC

*** This bug has been marked as a duplicate of 76226 ***


Note You need to log in before you can comment on or make changes to this bug.