Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79141 - [4.2.1-9] reproducible segfault in X
Summary: [4.2.1-9] reproducible segfault in X
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-06 08:45 UTC by Aleksey Nogin
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-07 13:32:19 UTC


Attachments (Terms of Use)
Warning: Clicking this link could crash your X! (deleted)
2002-12-06 08:49 UTC, Aleksey Nogin
no flags Details
X log (deleted)
2002-12-06 08:50 UTC, Aleksey Nogin
no flags Details
gdb stack trace (not too informative) (deleted)
2002-12-06 08:51 UTC, Aleksey Nogin
no flags Details
X Config (deleted)
2002-12-06 08:51 UTC, Aleksey Nogin
no flags Details
lspci -vv output (deleted)
2002-12-06 08:52 UTC, Aleksey Nogin
no flags Details
Simplified XF86Config that I used to reporduce the problem. (deleted)
2002-12-27 02:49 UTC, Aleksey Nogin
no flags Details
X log (running under the standard 2.4.18-19.8.0, using a simple config) (deleted)
2002-12-27 02:51 UTC, Aleksey Nogin
no flags Details

Description Aleksey Nogin 2002-12-06 08:45:45 UTC
Not sure if you still care about 4.2.1-9, reporting just in case (not sure if
bug exists in some other versions as well).

I came across a 100% reporducible crash in X, caused by gv (even in the absense
of any other X client, WM, etc):

env -i HOME=$HOME XAUTHORITY=$XAUTHORITY PATH=$PATH X :2 -auth $XAUTHORITY &
env -i HOME=$HOME XAUTHORITY=$XAUTHORITY PATH=$PATH DISPLAY=:2 gv /tmp/pentgrph.eps

and the X crashes (as soon as I switch to the virtual console under which this
instance of X is running). I'll attach all the relavant files shortly.

I am running 8.0 + most updates + XFree86-4.2.1-9 (I wanted to run Mozilla-xft,
so I wanted a version of X that has the xft bug fixed). The video card is
(according to lspci) "ATI Technologies Inc Radeon Mobility M7 LW [Radeon
Mobility 7500]" in Dell Latitude C640.

Comment 1 Aleksey Nogin 2002-12-06 08:49:37 UTC
Created attachment 87644 [details]
Warning: Clicking this link could crash your X!

Comment 2 Aleksey Nogin 2002-12-06 08:50:20 UTC
Created attachment 87645 [details]
X log

Comment 3 Aleksey Nogin 2002-12-06 08:51:11 UTC
Created attachment 87646 [details]
gdb stack trace (not too informative)

Comment 4 Aleksey Nogin 2002-12-06 08:51:51 UTC
Created attachment 87647 [details]
X Config

Comment 5 Aleksey Nogin 2002-12-06 08:52:42 UTC
Created attachment 87648 [details]
lspci -vv output

Comment 6 Mike A. Harris 2002-12-27 00:51:42 UTC
You are not using an official Red Hat kernel, you are using a custom
built kernel, which Red Hat does not support.

Is this problem reproduceable using the latest official Red Hat released
kernel erratum for RHL 8.0?

Comment 7 Mike A. Harris 2002-12-27 00:55:26 UTC
 Driver      "synaptics"

You are also using an input driver which is not part of Red Hat Linux,
and not supported by Red Hat.  Since externally supplied X driver modules
become part of the XFree86 process itself once dynamically loaded, your
entire setup is unsupported.  It also looks to me like the driver you've
added is what is causing the problem.

Closing bug NOTABUG.

Comment 8 Aleksey Nogin 2002-12-27 01:45:34 UTC
I replaces the synaptics driver with a normal IMPS/2 one and I still get the
crash. The custom kernel is almost identical to the Red Hat's one (same sources
with slightly different config settings), but to be sure I will test it using a
regular kernel too and will let you know.

Comment 9 Aleksey Nogin 2002-12-27 02:47:08 UTC
Yes, still getting the same crash under 2.4.18-19.8.0. I'll attach the relevant
files.

Comment 10 Aleksey Nogin 2002-12-27 02:49:34 UTC
Created attachment 88936 [details]
Simplified XF86Config that I used to reporduce the problem.

This does not use synaptics driver or (I believe) anything else nonstandard.

Comment 11 Aleksey Nogin 2002-12-27 02:51:05 UTC
Created attachment 88937 [details]
X log (running under the standard  2.4.18-19.8.0, using a simple config)

Comment 12 Aleksey Nogin 2003-01-06 07:59:15 UTC
FWIW, it works OK in Phoebe.

Comment 13 Mike A. Harris 2003-01-07 13:32:19 UTC
Closing as RAWHIDE


Note You need to log in before you can comment on or make changes to this bug.