Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79114 - modprobe usb-uhci hangs at boot
Summary: modprobe usb-uhci hangs at boot
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 21:22 UTC by Pontus Enhager
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-26 20:24:55 UTC


Attachments (Terms of Use)
output from lspci -vvv (deleted)
2002-12-05 21:23 UTC, Pontus Enhager
no flags Details

Description Pontus Enhager 2002-12-05 21:22:17 UTC
Description of Problem:
When booting the computer hangs at 4/5 occasions when reaching the point where
usb-uhci is initialised

Version-Release number of selected component (if applicable):
redhat 8.0
kernel 2.4.18-18-8 and 2.4.18-14
computer have to be turned off (button) as the keyboard is not initialised
yet(my guess)
How Reproducible:
4 out of 5 reboots

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
if adding the -xv suffix to rc.sysinit, the following lines are the two last

Initializing USB controller (usb-uhci): +shift
+ initlog -q -c 'modprobe usb-uhci'

Expected Results:
Normal boot

Additional Information:
Computer:IBM Netvista A30p
Intel p4
i845g motherboard
usb keyboard and mouse

Comment 1 Pontus Enhager 2002-12-05 21:23:10 UTC
Created attachment 87604 [details]
output from lspci -vvv

Comment 2 Pontus Enhager 2002-12-05 21:38:04 UTC
the correct model no of the computer is Netvista 8310-KRG as i just learned

Comment 3 Pontus Enhager 2002-12-19 07:24:59 UTC
I have managed to get the rawhide kernel-2.4.20-0.pp.11.src.rpm to compile and
boot on my computer and it seems to fix the hang (after approx 7 reboots) did
anything related go into that kernel ? will return with more feedback!


Comment 4 Pete Zaitcev 2002-12-19 09:12:52 UTC
I did not do anything specific, the usb-uhci we take completely from upstream.
Did _any_ sort of Red Hat kernel work on the box before, and if yes, what
was the version?


Comment 5 Pontus Enhager 2002-12-19 10:03:40 UTC
No previous redhat kernel have worked before (tested 2.4.18-[14,18.8]) this one
appears to work :-)

Comment 6 Pontus Enhager 2002-12-21 14:07:55 UTC
i have also tried pp-9 which did not boot at all so i cannot really tell...

Comment 7 Pontus Enhager 2002-12-26 20:24:55 UTC
Works also on 2.4.20-2.2 - i change resolution to RAWHIDE


Note You need to log in before you can comment on or make changes to this bug.