Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79113 - [RFE] gnome-cd uses an excessive amount of memory
Summary: [RFE] gnome-cd uses an excessive amount of memory
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-media
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 21:20 UTC by Michael Lee Yohe
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-05 21:20:55 UTC


Attachments (Terms of Use)

Description Michael Lee Yohe 2002-12-05 21:20:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
For a simple CD player, gnome-cd consumes much more memory than is absolutely
necessary - even for a simple GTK2 application.  gnome-cd, since it is the main
selection for Gnome 2, should have its fat trimmed aggressively.

From top:
32721 myohe     15   0 16040  11M  7284 S     0.5  1.4   6:02 gnome-cd

$ ps ax | grep gnome-cd
32721 ?        S      6:02 gnome-cd
$ cat /proc/32721/status
Name:	gnome-cd
State:	S (sleeping)
Tgid:	32721
Pid:	32721
PPid:	1
TracerPid:	0
Uid:	500	500	500	500
Gid:	500	500	500	500
FDSize:	32
Groups:	500 
VmSize:	   23428 kB
VmLck:	       0 kB
VmRSS:	   11328 kB
VmData:	    8848 kB
VmStk:	      64 kB
VmExe:	     100 kB
VmLib:	   11540 kB
SigPnd:	0000000000000000
SigBlk:	0000000080000000
SigIgn:	8000000000001000
SigCgt:	00000003800104f0
CapInh:	0000000000000000
CapPrm:	0000000000000000
CapEff:	0000000000000000

Oddly enough - upon running memprof on gnome-cd, my system locks up until I kill
(from a virtual terminal) all associated processes to memprof and gnome-cd.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see description
2.
3.
	

Actual Results:  see description

Expected Results:  see description

Additional info:

Comment 1 Havoc Pennington 2002-12-05 21:37:23 UTC
Should report this one on http://bugzilla.gnome.org, presumably involves
fairly pervasive code changes we would not do in a Red Hat specific patch.


Note You need to log in before you can comment on or make changes to this bug.