Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79109 - chart keys do not print properly non-ASCII characters
Summary: chart keys do not print properly non-ASCII characters
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnucash
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 19:54 UTC by David Monniaux
Modified: 2014-03-17 02:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-28 22:18:36 UTC


Attachments (Terms of Use)

Description David Monniaux 2002-12-05 19:54:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When used in an UTF-8 environment (unsure about other locales): the pie etc..
charts do not display accented characters in account names. Those characters are
just ignored.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Launch GnuCash over a non-empty set of accounts with expense account names
containing UTF-8 characters
2.Reports -> Profit and loss -> Expense piechart
3.
	

Actual Results:  Captions just skip accented characters

Expected Results:  They should display them properly

Additional info:

This is probably a bug in Guppi.

Comment 1 Bill Nottingham 2005-01-28 22:18:36 UTC
This is almost certianly due to the use of GTK+1, which isn't really
utf-8 safe.

Hopefully it will be fixed in the upcoming GNOME 2 port.


Note You need to log in before you can comment on or make changes to this bug.