Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79106 - kdebase-3.0.3-14 (Upgraded from 3.0.3-13) breaks X
Summary: kdebase-3.0.3-14 (Upgraded from 3.0.3-13) breaks X
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
: 84609 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 19:19 UTC by John Franks
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-05 19:19:54 UTC


Attachments (Terms of Use)

Description John Franks 2002-12-05 19:19:47 UTC
Description of Problem:
After upgrade to kdebase-3.0.3-14 (from 3.0.3-13) X server fails 
on reboot.  Error message says: can't find default font "fixed".
I have seen this on four or five machines (also with RH 7.3).
What these machines have in common is they all have Nvidia graphics
cards and they are all using Nvidia drivers.

The problem can be worked around in two ways.  
1. Revert to 3.0.3-13.
or 
2. Touch the file 
/usr/X11R6/lib/X11/fonts/misc/fonts.alias

I don't know why 2. works, but it seems to.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. upgrade to kdebase-3.0.3-14 (from 3.0.3-13)
2. reboot
3. 

Actual Results:
X server fails to start


Expected Results:
working X

Additional Information:
Seems related to Nvidia graphics drivers, I don't know how.

Comment 1 Ngo Than 2002-12-06 13:46:10 UTC
it looks like that XFree86-base-fonts was not installed on your machine. It's
strange, because it's installed as default!

anyway you should install it and it will work again afterwards.

Question: as i know i did not release kdebase-3.0.3-14. where have you got this rpm?



Comment 2 John Franks 2002-12-06 14:37:36 UTC
I have seen this on four computers running RH 7.3 and RH 8.0.  All of them have
XFree86-base-fonts-4.2.0-8 from RH installed. As a security policy we install
all upgrades from updates.redhat.com.  We check redhat signatures before
installing.  Two days ago there was a massive upgrade of kde (which we mostly do
not use but have installed on some machines).  This included
kdebase-3.0.3-0.7.2.i386.rpm
for RH 7.3 and kdebase-3.0.3-14 (Upgraded from 3.0.3-13) on RH 8.0.  

This upgrade package included two fonts

/usr/X11R6/lib/X11/fonts/misc/console8x16.pcf.gz
/usr/X11R6/lib/X11/fonts/misc/console8x8.pcf.gz

Somehow this broke X.  Touching the file 
/usr/X11R6/lib/X11/fonts/misc/fonts.alias 
fixes it.

Comment 3 John Franks 2002-12-18 23:31:36 UTC
I believe this bug is a duplicate of 79415.  It sure would have been nice to
hear that from someone who knows more than I do. I wonder if my "fix" of
touching the fonts.alias file and rebooting causes the fonts.dir file to be
rewritten with correct permissions, thus solving the problem (see 79415).


Comment 4 Benoit Dionne 2003-02-20 16:30:36 UTC
*** Bug 84609 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.