Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7910 - exit signal Segmentation fault (11) [httpsd Seg Faulting]
Summary: exit signal Segmentation fault (11) [httpsd Seg Faulting]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Secure Web Server
Classification: Retired
Component: secureweb
Version: 3.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
: 7911 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-20 20:38 UTC by Will
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-13 15:23:37 UTC


Attachments (Terms of Use)

Description Will 1999-12-20 20:38:55 UTC
httpsd seams to just die at times.

This has happened 3 times in the past 2 months.

I could not find a core file.

The only Help I can give is the log output.

Has anyone else reported this.

Thanks
Will

Log OutPut:
[notice] Apache/1.3.9 (Unix) Red-Hat-Secure/3.1 mod_perl/1.21 PHP/3.0.12
mod_ssl/2.4.5 OpenSSL/0.9.4 configured --
resuming normal operations
[Sun Dec 19 00:02:03 1999] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Sun Dec 19 00:43:43 1999] [notice] child pid 28417 exit signal
Segmentation fault (11)
[Sun Dec 19 12:57:19 1999] [notice] child pid 28419 exit signal
Segmentation fault (11)
[Sun Dec 19 12:57:24 1999] [notice] child pid 28414 exit signal
Segmentation fault (11)
[Sun Dec 19 12:57:28 1999] [notice] child pid 28422 exit signal
Segmentation fault (11)
[Sun Dec 19 12:59:27 1999] [notice] child pid 28752 exit signal
Segmentation fault (11)
[Sun Dec 19 13:37:23 1999] [notice] child pid 28755 exit signal
Segmentation fault (11)
[Sun Dec 19 14:10:56 1999] [notice] child pid 28420 exit signal
Segmentation fault (11)
[Sun Dec 19 14:11:09 1999] [notice] child pid 28421 exit signal
Segmentation fault (11)
[Sun Dec 19 14:12:02 1999] [notice] caught SIGTERM, shu

Comment 1 craigl 2000-01-10 21:55:59 UTC
i have been trying to track this down also.  For me, it seems to happen every
Sunday ( believe it or not! ).  I can find no rhyme or reason to any special
hits before it breaks.  At first, I thought I noticed some non-EXP grade clients
hitting it before it broke, but it seems to happen even without that.  I set the
'SSLLogLevel' to 'trace', but i find nothing unusual here at all.  Here is the
last few lines before it going down:

[19/Dec/1999 05:40:22 20459] [info]  Connection to child 9 established (server
XXX.com:443, client 209.214.22.129)
[19/Dec/1999 05:40:22 20459] [trace] Seeding PRNG with 1032 bytes of entropy
[19/Dec/1999 05:40:22 20459] [trace] OpenSSL: Handshake: start
[19/Dec/1999 05:40:22 20459] [trace] OpenSSL: Loop: before/accept
initialization[19/Dec/1999 05:40:22 20459] [trace] OpenSSL: Loop: SSLv3 read
client hello A
[19/Dec/1999 05:40:22 20459] [trace] OpenSSL: Loop: SSLv3 write server hello A
[19/Dec/1999 05:40:22 20459] [trace] OpenSSL: Loop: SSLv3 write change cipher
spec A
[19/Dec/1999 05:40:22 20459] [trace] OpenSSL: Loop: SSLv3 write finished A
[19/Dec/1999 05:40:22 20459] [trace] OpenSSL: Loop: SSLv3 flush data
[19/Dec/1999 05:40:23 20459] [trace] OpenSSL: Loop: SSLv3 read finished A
[19/Dec/1999 05:40:23 20459] [trace] OpenSSL: Handshake: done
[19/Dec/1999 05:40:23 20459] [info]  Connection: Client IP: 209.214.22.129,
Protocol: SSLv3, Cipher: RC4-MD5 (128/128 bits)
[19/Dec/1999 05:40:24 20459] [trace] OpenSSL: Write: SSL negotiation finished
successfully
[19/Dec/1999 05:40:24 20459] [info]  Connection to child 9 closed with standard
shutdown (server XXX.com:443, client 209.214.22.129)
[19/Dec/1999 05:41:32 20468] [info]  Connection to child 7 established (server
XXX.com:443, client 209.214.22.129)
[19/Dec/1999 05:41:32 20468] [trace] Seeding PRNG with 1032 bytes of entropy
[19/Dec/1999 05:41:32 20468] [trace] OpenSSL: Handshake: start
[19/Dec/1999 05:41:32 20468] [trace] OpenSSL: Loop: before/accept
initialization[19/Dec/1999 05:41:32 20468] [trace] OpenSSL: Loop: SSLv3 read
client hello A
[19/Dec/1999 05:41:32 20468] [trace] OpenSSL: Loop: SSLv3 write server hello A
[19/Dec/1999 05:41:32 20468] [trace] OpenSSL: Loop: SSLv3 write change cipher
spec A
[19/Dec/1999 05:41:32 20468] [trace] OpenSSL: Loop: SSLv3 write finished A
[19/Dec/1999 05:41:32 20468] [trace] OpenSSL: Loop: SSLv3 flush data
[19/Dec/1999 05:41:33 20468] [trace] OpenSSL: Loop: SSLv3 read finished A
[19/Dec/1999 05:41:33 20468] [trace] OpenSSL: Handshake: done
[19/Dec/1999 05:41:33 20468] [info]  Connection: Client IP: 209.214.22.129,
Protocol: SSLv3, Cipher: RC4-MD5 (128/128 bits)
[19/Dec/1999 05:41:33 20468] [trace] OpenSSL: Write: SSL negotiation finished
successfully
[19/Dec/1999 05:41:33 20468] [info]  Connection to child 7 closed with standard
shutdown (server XXX.com:443, client 209.214.22.129)
[19/Dec/1999 06:45:07 20468] [info]  Connection to child 7 established (server
YYY.com:443, client 194.168.57.135)
[19/Dec/1999 06:45:07 20468] [trace] Seeding PRNG with 1032 bytes of entropy
[19/Dec/1999 06:45:07 20468] [trace] OpenSSL: Handshake: start
[19/Dec/1999 06:45:07 20468] [trace] OpenSSL: Loop: before/accept
initialization[19/Dec/1999 06:45:07 20468] [trace] OpenSSL: Loop: SSLv3 read
client hello A
[19/Dec/1999 06:45:07 20468] [trace] OpenSSL: Loop: SSLv3 write server hello A
[19/Dec/1999 06:45:07 20468] [trace] OpenSSL: Loop: SSLv3 write certificate A
[19/Dec/1999 06:45:07 20468] [trace] OpenSSL: Loop: SSLv3 write key exchange A
[19/Dec/1999 06:45:07 20468] [trace] OpenSSL: Loop: SSLv3 write server done A
[19/Dec/1999 06:45:07 20468] [trace] OpenSSL: Loop: SSLv3 flush data
[19/Dec/1999 17:06:27 20467] [info]  Connection to child 3 established (server
YYY.com:443, client 24.112.183.162)
[19/Dec/1999 17:06:27 20467] [trace] Seeding PRNG with 1032 bytes of entropy
[19/Dec/1999 17:06:27 20467] [trace] OpenSSL: Handshake: start
[19/Dec/1999 17:06:27 20467] [trace] OpenSSL: Loop: before/accept
initialization[19/Dec/1999 17:06:28 20467] [trace] OpenSSL: Loop: SSLv3 read
client hello A
[19/Dec/1999 17:06:28 20467] [trace] OpenSSL: Loop: SSLv3 write server hello A
[19/Dec/1999 17:06:28 20467] [trace] OpenSSL: Loop: SSLv3 write certificate A
[19/Dec/1999 17:06:28 20467] [trace] OpenSSL: Loop: SSLv3 write key exchange A
[19/Dec/1999 17:06:28 20467] [trace] OpenSSL: Loop: SSLv3 write server done A
[19/Dec/1999 17:06:28 20467] [trace] OpenSSL: Loop: SSLv3 flush data
[19/Dec/1999 17:09:40 20460] [info]  Connection to child 5 established (server
YYY.com:443, client 24.112.183.162)
[19/Dec/1999 17:09:40 20460] [trace] Seeding PRNG with 1032 bytes of entropy
[19/Dec/1999 17:09:40 20460] [trace] OpenSSL: Handshake: start
[19/Dec/1999 17:09:40 20460] [trace] OpenSSL: Loop: before/accept
initialization[19/Dec/1999 17:09:40 20460] [trace] OpenSSL: Loop: SSLv3 read
client hello A
[19/Dec/1999 17:09:40 20460] [trace] OpenSSL: Loop: SSLv3 write server hello A
[19/Dec/1999 17:09:40 20460] [trace] OpenSSL: Loop: SSLv3 write certificate A
[19/Dec/1999 17:09:40 20460] [trace] OpenSSL: Loop: SSLv3 write key exchange A
[19/Dec/1999 17:09:40 20460] [trace] OpenSSL: Loop: SSLv3 write server done A
[19/Dec/1999 17:09:40 20460] [trace] OpenSSL: Loop: SSLv3 flush data
[19/Dec/1999 17:10:31 20461] [info]  Connection to child 4 established (server
YYY.com:443, client 24.112.183.162)
[19/Dec/1999 17:10:31 20461] [trace] Seeding PRNG with 1032 bytes of entropy
[19/Dec/1999 17:10:31 20461] [trace] OpenSSL: Handshake: start
[19/Dec/1999 17:10:31 20461] [trace] OpenSSL: Loop: before/accept
initialization[19/Dec/1999 17:10:32 20461] [trace] OpenSSL: Loop: SSLv3 read
client hello A
[19/Dec/1999 17:10:32 20461] [trace] OpenSSL: Loop: SSLv3 write server hello A
[19/Dec/1999 17:10:32 20461] [trace] OpenSSL: Loop: SSLv3 write certificate A
[19/Dec/1999 17:10:32 20461] [trace] OpenSSL: Loop: SSLv3 write key exchange A
[19/Dec/1999 17:10:32 20461] [trace] OpenSSL: Loop: SSLv3 write server done A
[19/Dec/1999 17:10:32 20461] [trace] OpenSSL: Loop: SSLv3 flush data


The connection at 06:45:07 is the first one that doesn't seem to close
properely.  That connection was from somewhere else, so I'm not sure if it
worked or not.  But all the remaining ones ( client addr 24.112.183.162 ) are
from my testing this, and they all failed.  The client simply sees a browser
error along the lines of 'I/O Error communicating with server'.

Otherwise, this is a pretty basic server.  It is multi-homed, and has two SSL
sites on it.  We are using a 128bit server key.

Any other information helpful?  I really do need to get this fixed.  It is
incredibly embarassing to have our linux/apache box need to be rebooted once a
week, my pitch to moving away from NT was that they wouldn't have to be rebooted
once a week.  Annoyingly ironic?

Comment 2 Preston Brown 2000-01-13 15:23:59 UTC
*** Bug 7911 has been marked as a duplicate of this bug. ***this is being addressed in a forthcoming errata release this week.


Note You need to log in before you can comment on or make changes to this bug.