Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79099 - screen display problems
Summary: screen display problems
Keywords:
Status: CLOSED DUPLICATE of bug 78392
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: screen
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 17:46 UTC by Aric Blumer
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-05 18:00:12 UTC


Attachments (Terms of Use)
Garbled screen (ignore ???--that's not the problem) (deleted)
2002-12-05 17:52 UTC, Aric Blumer
no flags Details
What it looks like with RH7.3's screen (deleted)
2002-12-05 17:54 UTC, Aric Blumer
no flags Details

Description Aric Blumer 2002-12-05 17:46:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
Screen is not displaying correctly with some programs. For example, the ntsysv
program display is garbled in screen.

Version-Release number of selected component (if applicable):
3.9.11-10


How reproducible:
Always

Steps to Reproduce:
1. Run gnome-terminal or xterm
2. Run ntsysv (as root).  Everything is fine.  Quit
3. Run screen
4. Run ntsysv.  The screen is messed up. quit
5. rpm -e screen.  Install screen from RH7.3.  Repeat above steps, and
everything is fine.
	

Actual Results:  The screen is garbled.  I have a screenshot.

Expected Results:  Proper display

Additional info:

RH7.3 has screen-3.9.11-3.  Works fine.
RH8.0 has screen-3.9.11-10.  Doesn't work.

Comment 1 Aric Blumer 2002-12-05 17:52:11 UTC
Created attachment 87566 [details]
Garbled screen (ignore ???--that's not the problem)

Comment 2 Aric Blumer 2002-12-05 17:54:53 UTC
Created attachment 87567 [details]
What it looks like with RH7.3's screen

Comment 3 Aric Blumer 2002-12-05 18:00:05 UTC
I slightly goofed with the first attachment.  The ??? may be another
manifestation of the problem.

Comment 4 Lon Hohberger 2002-12-05 21:05:20 UTC
Screen, as shipped with RHL8.0 does not support UTF-8 character encodings, which
is the default.

Put this in your .bashrc for now:

alias ntsysv 'LANG=`echo $LANG | sed -e s/\.UTF-8//g` /usr/sbin/ntsysv'

or

alias ntsysv 'LANG=C /usr/sbin/ntsysv'

Please see bug #78392; I will keep that one more up to date.

*** This bug has been marked as a duplicate of 78392 ***


Note You need to log in before you can comment on or make changes to this bug.