Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79092 - Locales missing from RPM
Summary: Locales missing from RPM
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xsane
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 16:44 UTC by Jirtme Zago
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-05 16:47:30 UTC


Attachments (Terms of Use)
This fixes the bug on my system (deleted)
2002-12-05 16:47 UTC, Jirtme Zago
no flags Details | Diff

Description Jirtme Zago 2002-12-05 16:44:14 UTC
Description of problem: 
My system is in french (LANG=fr_FR.UTF-8) but everything xsane displays is in english. 
 
Version-Release number of selected component (if applicable): 
0.84-8 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
rpm -q -l xsane | grep locale; echo EOF 
 
Actual Results: 
EOF 
 
Expected Results: 
/usr/share/locale/cs 
/usr/share/locale/cs/LC_MESSAGES 
/usr/share/locale/cs/LC_MESSAGES/xsane.mo 
/usr/share/locale/de 
/usr/share/locale/de/LC_MESSAGES 
/usr/share/locale/de/LC_MESSAGES/xsane.mo 
/usr/share/locale/es 
/usr/share/locale/es/LC_MESSAGES 
/usr/share/locale/es/LC_MESSAGES/xsane.mo 
/usr/share/locale/fr 
/usr/share/locale/fr/LC_MESSAGES 
/usr/share/locale/fr/LC_MESSAGES/xsane.mo 
/usr/share/locale/it 
/usr/share/locale/it/LC_MESSAGES 
/usr/share/locale/it/LC_MESSAGES/xsane.mo 
/usr/share/locale/ja 
/usr/share/locale/ja/LC_MESSAGES 
/usr/share/locale/ja/LC_MESSAGES/xsane.mo 
/usr/share/locale/nl 
/usr/share/locale/nl/LC_MESSAGES 
/usr/share/locale/nl/LC_MESSAGES/xsane.mo 
/usr/share/locale/ru 
/usr/share/locale/ru/LC_MESSAGES 
/usr/share/locale/ru/LC_MESSAGES/xsane.mo 
/usr/share/locale/sl 
/usr/share/locale/sl/LC_MESSAGES 
/usr/share/locale/sl/LC_MESSAGES/xsane.mo 
/usr/share/locale/sr 
/usr/share/locale/sr/LC_MESSAGES 
/usr/share/locale/sr/LC_MESSAGES/xsane.mo 
/usr/share/locale/sv 
/usr/share/locale/sv/LC_MESSAGES 
/usr/share/locale/sv/LC_MESSAGES/xsane.mo 
/usr/share/locale/tr 
/usr/share/locale/tr/LC_MESSAGES 
/usr/share/locale/tr/LC_MESSAGES/xsane.mo 
EOF

Comment 1 Jirtme Zago 2002-12-05 16:47:24 UTC
Created attachment 87544 [details]
This fixes the bug on my system

Comment 2 Tim Waugh 2002-12-05 16:51:53 UTC
Did you try the latest rawhide package?

* Fri Oct 25 2002 Tim Waugh <twaugh@redhat.com> 0.89-1

- 0.89.
- Use %find_lang.


Comment 3 Jirtme Zago 2002-12-05 18:52:05 UTC
Actually, my patch didn't work so well with default LANG=fr_FR.UTF-8, since strings with  
"french" characters weren't displayed. It worked with LANG=fr_FR though. 
 
Anyway the RawHide package seems to solve this problem, thanks a lot !


Note You need to log in before you can comment on or make changes to this bug.