Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79069 - gnome_segv segfaults
Summary: gnome_segv segfaults
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
: 78993 79089 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 10:20 UTC by Tim Waugh
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-06 15:31:50 UTC


Attachments (Terms of Use)

Description Tim Waugh 2002-12-05 10:20:40 UTC
Description of Problem:
gnome_segv shouldn't segfault, but it does.

Version-Release number of selected component (if applicable):
gnome-libs-1.4.1.2.90-26

How Reproducible:
100%

Steps to Reproduce:
1. gnome_segv guile 11 1.7.5

Actual Results:
Segfault.

Starting program: /usr/bin/gnome_segv guile 11 1.7.5

Program received signal SIGSEGV, Segmentation fault.
0x42078183 in strlen () from /lib/i686/libc.so.6
(gdb) bt
#0  0x42078183 in strlen () from /lib/i686/libc.so.6
#1  0x406c5427 in _Xutf8DefaultDrawImageString ()
   from /usr/X11R6/lib/X11/locale/lib/common/xomGeneric.so.2
#2  0x406c5818 in _Xutf8DefaultDrawImageString ()
   from /usr/X11R6/lib/X11/locale/lib/common/xomGeneric.so.2
#3  0x406c5df2 in destroy_fontdata ()
   from /usr/X11R6/lib/X11/locale/lib/common/xomGeneric.so.2
#4  0x403e8bc3 in XCreateOC () from /usr/X11R6/lib/libX11.so.6
#5  0x403e7f5d in XCreateFontSet () from /usr/X11R6/lib/libX11.so.6
#6  0x40338bab in gdk_fontset_load () from /usr/lib/libgdk-1.2.so.0
#7  0x4029e345 in gtk_rc_style_to_style () from /usr/lib/libgtk-1.2.so.0
#8  0x4029e5d5 in gtk_rc_style_init () from /usr/lib/libgtk-1.2.so.0
#9  0x4029d95e in gtk_rc_get_style () from /usr/lib/libgtk-1.2.so.0
#10 0x402efacf in gtk_widget_set_rc_style () from /usr/lib/libgtk-1.2.so.0
#11 0x402ef946 in gtk_widget_ensure_style () from /usr/lib/libgtk-1.2.so.0
#12 0x402ebd60 in gtk_widget_size_request () from /usr/lib/libgtk-1.2.so.0
#13 0x400c7936 in gnome_stock_paint () from /usr/lib/libgnomeui.so.32
#14 0x400c8224 in gnome_stock_set_icon () from /usr/lib/libgnomeui.so.32
#15 0x400c833d in gnome_stock_new_with_icon () from /usr/lib/libgnomeui.so.32
#16 0x400c9585 in gnome_stock_pixmap_widget () from /usr/lib/libgnomeui.so.32
#17 0x400c9c63 in stock_button_from_entry () from /usr/lib/libgnomeui.so.32
#18 0x400c9d74 in gnome_stock_or_ordinary_button ()
   from /usr/lib/libgnomeui.so.32
#19 0x40082c74 in gnome_dialog_append_button () from /usr/lib/libgnomeui.so.32
#20 0x400b7b8d in gnome_message_box_new () from /usr/lib/libgnomeui.so.32
#21 0x0804904a in main ()
#22 0x42015987 in __libc_start_main () from /lib/i686/libc.so.6

Comment 1 Mike A. Harris 2002-12-05 12:48:49 UTC
All your bug are belong to me.

Comment 2 Mike A. Harris 2002-12-05 12:51:50 UTC
*** Bug 78993 has been marked as a duplicate of this bug. ***

Comment 3 Need Real Name 2002-12-06 15:14:40 UTC
With XFree86-4.2.99.2-0.20021126.8, it's OK now.

Thanks.
Keep the good work.

Comment 4 Mike A. Harris 2002-12-06 15:31:41 UTC
*** Bug 79089 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.