Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79067 - Ntpd does not work with non-fixed interfaces
Summary: Ntpd does not work with non-fixed interfaces
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 10:12 UTC by Jos Vos
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-05 10:12:32 UTC


Attachments (Terms of Use)

Description Jos Vos 2002-12-05 10:12:26 UTC
Description of Problem:
Ntpd seems to look only once, at startup time, to the local addresses for
binding purposes.  This means that you run into trouble with for example
ADSL/cable/dial-up PPP interfaces and with VPN tunnels, of which the interface
and address is available after ntpd startup.  NTP packets will then be generated
using a wrong source address (e.g., this might be a private address), which
might not work, either because of routing issues or by firewall blocks.

Version-Release number of selected component (if applicable):
4.1.1a-9 (applies to all versions I know).

Steps to Reproduce:
1. Set up a system with an 192.168.x.y address.
2. Do not enable masquerading.
3. Start ntpd.
4. Make a PPP connection with a default route.
5. Let ntpd talk to a public NTP server.

Actual Results:
Packets will be sent out with a 192.168.x.y address.

Expected Results:
Packats are sent out with the external PPP address.

Comment 1 Harald Hoyer 2002-12-05 10:19:31 UTC
how about /sbin/service ntp restart in /etc/ppp/ip-up.local ??
I will not fix this. Please mail this "Request for Extension" to bugs@ntp.org, thx.

Comment 2 Jos Vos 2002-12-05 10:29:08 UTC
Your ip-up.local hint is what already I did (as well as in
/etc/cipe/ip-up.local), although I used "condrestart" ;-).  But a more
structural solution would be better. Anyway, I will post the bug to bugs@ntp.org.


Note You need to log in before you can comment on or make changes to this bug.