Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79046 - libgdbm.la includes incorrect libdir
Summary: libgdbm.la includes incorrect libdir
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdbm
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-05 01:05 UTC by Jeffrey Hutzelman
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-23 11:56:19 UTC


Attachments (Terms of Use)

Description Jeffrey Hutzelman 2002-12-05 01:05:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.17 i686)

Description of problem:
gdbm-devel contains /usr/lib/libgdbm.la which specifies libdir='/usr/local/lib',
but the libraries are actually in /usr/lib.
This causes libtool-using programs which need libgdbm to fail to link, and also
poisons dependencies in .la files built for other libtool-using libraries.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
# grep libdir /usr/lib/libgdbm.la
libdir='/usr/local/lib'

# rpm --query -f /usr/lib/libgdbm.la
gdbm-devel-1.8.0-5

# rpm --verify gdbm-devel
(produces no output, indicating the files are as shipped)


Additional info:

Workaround is to edit /usr/lib/libgdbm.la, changing libdir to /usr/lib. 
Naturally, this must be done on every machine.  Because this problem affects .la
files generated when building other libtool-using libraries which link against
libgdbm, and because it does _not_ affect linking programs which do not use
libtool, it may be difficult to recognize that a fix is needed.

An appropriate solution to this problem would be to fix the build process so
that an incorrect libgdbm.la is not installed.

Comment 1 Jeff Johnson 2004-08-23 11:56:19 UTC
Current gdbm-devel-1.8.0-24 contains
    libdir=/usr/lib


Note You need to log in before you can comment on or make changes to this bug.