Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79038 - quota-3.01pre9-3 - problem w/ 32 bit UIDs
Summary: quota-3.01pre9-3 - problem w/ 32 bit UIDs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: quota
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 21:50 UTC by Dave Maley
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-03 16:49:27 UTC


Attachments (Terms of Use)

Description Dave Maley 2002-12-04 21:50:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I'm working w/ a client who's having some trouble w/ quotas on an AS 2.1 system.
 He has quota-3.01pre9-3 installed currently.  

When he does a quotaoff, and then a quotaon, it appears to stop and start quotas
properly.  However if he then checks the quota for a specific user, it comes
back saying none.  This apparently isn't a problem when he is using quota-tools
v3.07 (quota-3.0.7 compiled from sourceforge).

He mentioned that he's using nss_ldap w/ 32 bit UID's.  He also
mentioned that repquota seems to have problems displaying users w/ 32
bit UID's.

Version-Release number of selected component (if applicable): quota-3.01pre9-3


How reproducible:
Always

Steps to Reproduce:
Seems specific to nss_ldap w/ 32 bit UIDs

1.quotaoff
2.quotaon
3.check quota for user -> shows none
	

Actual Results:  none is displayed when checking quota for the user

Expected Results:  the correct quota info should be displayed

Additional info:

I was not able to reproduce this scenerio on my AS 2.1 system.  However I am not
using ldap w/ 32 bit UIDs.

Comment 1 Dave Maley 2002-12-10 20:41:21 UTC
Client reports that quota-3.0.7 (compiled from sourceforge) works as expected w/
32 bit UIDs:

http://sourceforge.net/project/showfiles.php?group_id=18136


Note You need to log in before you can comment on or make changes to this bug.