Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79036 - GtkSpinButton climb-rate is set properly in Glade XML, but "Adjustment" is *NOT*
Summary: GtkSpinButton climb-rate is set properly in Glade XML, but "Adjustment" is *NOT*
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glade2
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 20:33 UTC by Hardy Merrill
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-04 20:42:05 UTC


Attachments (Terms of Use)

Description Hardy Merrill 2002-12-04 20:33:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When setting the climb-rate on a GtkSpinButton widget in Glade2 to anything
other than 1, the following happens:
  1. The xml output correctly shows the right value for the climb-rate property, but
  2. Since the "adjustment" property seems to control the GtkSpinButton
functionality, that "adjustment" property's 4th value(climb-rate) still shows
"1", which does *NOT* reflect its changed value.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a GtkSpinButton widget using Glade2 - leave the climb-rate at the
default setting of 1.
2.save the glade project
3.inspect the .glade output file - find the GtkSpinButton widget, and
    confirm the value of the "climb-rate" property is 1, *and* that
    the 4th element in the "adjustment" property's value is also 1.
4.go back into glade2, and change the GtkSpinButton "climb-rate" to 10.
5.save the project
6.inspect the glade xml output file - confirm that the "climb_rate"
    property has the correct value of 10.  Also confirm that the
    "adjustment" property has the incorrect 4th element(climb_rate)
    value of 1.
	

Additional info:

Comment 1 Havoc Pennington 2002-12-04 20:41:56 UTC
Fourth adjustment value is step_increment, that's not the same as climb rate. 
the climb rate is the rate of acceleration if you hold down the mouse button 
on the arrow. The step_increment is the initial increment, and the climb rate 
grows the increment over time.

Comment 2 Hardy Merrill 2002-12-04 22:26:06 UTC
Here's what happens - when I changed the climb-rate in glade(2), saved the
project , and then tested it, the climb rate(when I clicked on the up-arrow of
the spinbutton) still incremented by 1.  I wanted each click on the up-arrow to
result in an increment of 10.<br>
<br>
So I tried changing the 4th value of the adjustment property from 1 to 10, and
then tested it - then, each click on the up-arrow resulted in an increment of
10, which is what I wanted.<br>
<br>
I see now - as you suggested, the "Step Increment" is the glade control that I
want to change from 1 to 10, to get the behavior I'm looking for.  I'm closing
this non-bug.


Note You need to log in before you can comment on or make changes to this bug.