Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79031 - autoconf-2.56 package requires emacs to build properly
Summary: autoconf-2.56 package requires emacs to build properly
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf
Version: 1.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 18:26 UTC by David Hollis
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-21 08:44:51 UTC


Attachments (Terms of Use)

Description David Hollis 2002-12-04 18:26:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021020

Description of problem:
Rebuilding the source RPM for autoconf 2.56 on a system without Emacs installed
fails because /usr/share/emacs/site-lisp does not get generated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Rebuild autoconf-2.56 on a system without emacs installed
2. Build fails at the final packaging state due to missing file site-lisp
3.
	

Actual Results:  PreReq: /sbin/install-info /bin/sh /bin/sh
Requires(interp): /bin/sh /bin/sh
Requires(post): /sbin/install-info /bin/sh
Requires(preun): /sbin/install-info /bin/sh
Requires: gawk m4 mktemp perl textutils
Obsoletes: autoconf253
 
 
RPM build errors:
    File not found: /var/tmp/autoconf-root/usr/share/emacs/site-lisp


Additional info:

<snippet from the %install portion>

if test no != no; then \
  EMACS=no /bin/sh ../../config/elisp-comp autoconf-mode.el; \
else : ; fi
WARNING: Warnings can be ignored. :-)
if test no != no; then \
  EMACS=no /bin/sh ../../config/elisp-comp autotest-mode.el; \
else : ; fi

Comment 1 Jens Petersen 2002-12-05 07:37:57 UTC
Thanks for the report.  For the time being, I'm adding "emacs" to the
buildrequires of the package.

This change should appear in autoconf-2.57-1 in rawhide shortly.


Note You need to log in before you can comment on or make changes to this bug.