Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79030 - Undhandled Exception when editing network hardware configuation
Summary: Undhandled Exception when editing network hardware configuation
Keywords:
Status: CLOSED DUPLICATE of bug 76226
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 18:15 UTC by n
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-04 18:15:58 UTC


Attachments (Terms of Use)

Description n 2002-12-04 18:15:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When I click edit under Network Configuration tool -> adapter -> hardware, there
is an unhandled exception that it tells me to report as a bug... which I am now
doing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open Red Hat Control Network
2.Click configure (alt + c)
3.enter root pasword
4.go to hardware tab
5.clik edit (alt + e)
	

Actual Results:  Undhandled exception notification appears

Expected Results:  Not sure, haven't clicked that button before

Additional info:

The exception box contained this
====

Please visit http://bugzilla.redhat.com/bugzilla/ !
File a bug against component redhat-config-network. Thank you!

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1248, in on_hardwareEditButton_clicked
    self.showHardwareDialog(type, true)
  File "/usr/sbin/neat", line 1269, in showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 75, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 135, in setup
    list.append(modInfo[i]['description'])
KeyError: description
====
I have a two devices installed.  A working ethernet card, and a non-functional
wireless card.  I was trying to debug my wireless card when I got this error,
but I get the error when I "edit" the working device too.

Comment 1 Harald Hoyer 2002-12-05 10:05:51 UTC

*** This bug has been marked as a duplicate of 76226 ***


Note You need to log in before you can comment on or make changes to this bug.