Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79022 - Problem in krb5_kuserok library call for long usernames
Summary: Problem in krb5_kuserok library call for long usernames
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: krb5
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 16:53 UTC by Keith Milligan
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version: krb5-1.2.7-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-07 19:09:25 UTC


Attachments (Terms of Use)

Description Keith Milligan 2002-12-04 16:53:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Verification of long userids will fail for any program that calls krb5_kuserok
(which includes newer versions of pam_krb5 and openssh).  This is due to a
define in kuserok.c that limits accounts to 9 characters.  I e-mailed the
Kerberos mailing list about this and they responded that increasing this limit
was a reasonable thing to do.  I'm including a patch for this as additional
information.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enable Kerberos logins for the system
2. Create an account with a username of >= 10 characters
3. Try to log in
	

Actual Results:  The account no longer functions when Kerberized.

Additional info:

--- src/lib/krb5/os/kuserok.c   2000-04-28 22:33:58.000000000 -0400
+++ src/lib/krb5/os/kuserok.c.mod       2002-12-04 11:16:11.000000000 -0500
@@ -38,7 +38,7 @@
 #define getpwnam(user) getpwnam((char *)user)
 #endif

-#define MAX_USERNAME 10
+#define MAX_USERNAME 64

 /*
  * Given a Kerberos principal "principal", and a local username "luser",

Comment 1 Bill Nottingham 2006-08-07 18:54:39 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.

Comment 2 Nalin Dahyabhai 2006-08-07 19:09:25 UTC
This was fixed somewhere between krb5 1.2.2 and 1.2.7.  Closing.


Note You need to log in before you can comment on or make changes to this bug.