Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79021 - c++ compiler does not recognize redefinition in the file scope
Summary: c++ compiler does not recognize redefinition in the file scope
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 16:52 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 10:46:33 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-04 16:52:00 UTC
Description of Problem: This problem is actual for compiler c++ in Red Hat 8.0 
only. Test case works properly( without error) in Red Hat 7.3. Compiler c++  
does not recognize rypedef name redefinition in the file scope.
We have the next text for file test.C:
namespace kr
{
    typedef long krina;
}
using kr::krina;

typedef char krina;

Command line:c++ test.C
Compiler does not emits any error. 

If we compile this file with any another c++ language compiler we have the 
error due to redefinition of identifier "krina".  
 



Version-Release number of selected component (if applicable):
Command line:c++ -v
Compiler emits the next information about version:
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --
infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-
checking --host=i386-redhat-linux --with-system-zlib --enable-__cxa_atexit
Thread model: posix
gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)



How Reproducible:


Steps to Reproduce:
1. To make file test.C, as described in report.
2. To execute command line:c++ test.C
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Richard Henderson 2004-10-03 10:46:33 UTC
Fails through gcc 3.3; fixed in gcc 3.4.


Note You need to log in before you can comment on or make changes to this bug.