Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79018 - rc.sysinit fails to load volume groups
Summary: rc.sysinit fails to load volume groups
Keywords:
Status: CLOSED DUPLICATE of bug 77539
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lvm
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Stephen Tweedie
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 16:40 UTC by Paul Witting
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-04 16:40:58 UTC


Attachments (Terms of Use)

Description Paul Witting 2002-12-04 16:40:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; H010818; .NET 
CLR 1.0.3705)

Description of problem:
The condition check in rc.sysinit for LVM

if [ -e /proc/lvm -a -x /sbin/vgchange -a -f /etc/lvmtab ]; then

because at this point /proc/lvm fails the existance check. Removing this check 
loads the volume groups properly

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a vg, lv, then put a file system on it.
2. Enter the file system into /etc/fstab
3. Reboot
4. Boot fails and drops to single user mode because the disk is unavailable. 

	

Actual Results:  Boot fails to complete, leaves machine in single user mode 
because mount -a fails. (Because LVM does not load, the volume in /etc/fstab is 
not available) 

Expected Results:  Boot to normal runlevel

Additional info:

I believe that once in runlevel 1 (Single User Mode), the /proc/lvm directory 
does exist, which makes troubleshooting the problem annoying. 

Since this could cause a system to fail to boot, I'm classifying it as a "High" 
bug, though I believe LVM is officially "not supported" the fact that the stock 
rc.sysinit attempts to load it merits consideration.

Comment 1 Stephen Tweedie 2002-12-06 23:39:19 UTC
It's not a bug, you need to have LVM in your initrd for the autostart to work.


*** This bug has been marked as a duplicate of 77539 ***


Note You need to log in before you can comment on or make changes to this bug.