Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79007 - Link per-user control panels to related system panels (was applet should allow user to select a mouse type by spawning redhat-config-mouse)
Summary: Link per-user control panels to related system panels (was applet should allo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: control-center
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 15:47 UTC by Michael Lee Yohe
Modified: 2013-04-02 04:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-21 09:23:24 UTC


Attachments (Terms of Use)

Description Michael Lee Yohe 2002-12-04 15:47:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Mouse configuration under Red Hat Linux 8 tends to be a bit ambiguous because
there are two applications that control the mouse.

gnome-mouse-properties
redhat-config-mouse

Having a tab under gnome-mouse-properties that contains the same information as
redhat-config-mouse, _OR_ a simple button that would spawn redhat-config-mouse
for them would help eliminate this ambiguity.

The tab option could be feasible if the application were modified to detect
whether the user had root level privileges.  Otherwise, the option would be
grayed out or unavailable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see description
2.
3.
	

Actual Results:  see description

Expected Results:  see description

Additional info:

$ rpm -qf `which gnome-mouse-properties`
control-center-2.0.1-8

Comment 1 Havoc Pennington 2002-12-04 15:56:21 UTC
Yeah, there's a general problem of how to present the systemwide prefs 
("System Settings") vs. the per-user prefs ("Preferences").

Most people find having two menus confusing, on the other hand, 
you really would not want to encourage someone to change settings for 
every user on the system thinking they were only affecting themselves...
and there's the implementation issue that you can't have one dialog 
where part of it runs as root and part does not. And the organizational 
issue that GNOME writes the Preferences and Red Hat writes the System 
Settings.

Comment 2 Marco Pesenti Gritti 2004-10-21 09:23:24 UTC
AFAICS there is no more system wide mouse setting UI in current release.


Note You need to log in before you can comment on or make changes to this bug.