Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79003 - rc.sysinit never runs isapnp as ! -f /proc/isapnp is false
Summary: rc.sysinit never runs isapnp as ! -f /proc/isapnp is false
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-04 15:34 UTC by James T Evans
Modified: 2014-03-17 02:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-04 15:34:44 UTC


Attachments (Terms of Use)

Description James T Evans 2002-12-04 15:34:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
I rely on isapnp to configure an ISA ISDN card. rc.sysinit contains the check 

"if [ -x /sbin/isapnp -a -f /etc/isapnp.conf -a ! -f /proc/isapnp ] then" ..... 
run isapnp if $PNP = yes. 

/proc/isapnp always seems to be there at the time this runs, so my isdn hardware
was never configured and the later "isdn start" would fail to find the card.

I removed the last term, checking for ! /proc/isapnp and the problem is resolved
though I am unclear as to the implications of this or why this has caused no-one
else a problem! maybe /proc/isapnp is not normally created at this time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.err start the system??
2.
3.
	

Additional info:

Comment 1 Bill Nottingham 2002-12-04 17:29:12 UTC
Running the userland isapnp tools while the kernel mode ISAPnP support
(/proc/isapnp) is active can be dangerous in some cases; that's why the check is
there.


Note You need to log in before you can comment on or make changes to this bug.