Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78958 - lcp-echo* options blocks pppd from connecting
Summary: lcp-echo* options blocks pppd from connecting
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL: n/a
Whiteboard:
Depends On:
Blocks: 78984
TreeView+ depends on / blocked
 
Reported: 2002-12-03 22:46 UTC by MIchael Kolmodin
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-13 09:10:53 UTC


Attachments (Terms of Use)

Description MIchael Kolmodin 2002-12-03 22:46:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
I have configured pppd to call my ISP through a USB-connected serial device. The
connection script works OK. However, if I add the lcp-echo* options in order to
supervise my connection which does not handle DCD/DTR, the connection fails. The
logfile shows that my system only sends lcp-echo-request, nothing else (it
should configure the link)

Version-Release number of selected component (if applicable):ppp-2.4.1-2


How reproducible:
Always

Steps to Reproduce:
1.Create a ppp configuration which calls to my ISP
2.Verify that it works
3.Add lcp-echo-interval and lcp-echo-failure options to pppd (I used a
  configuration under /etc/ppp/peers, but I presume using PPPOPTIONS
  in ifcfg-ppp0 will give the same result)
4 Try to connect, watch failere
5 If not done, add 'debug' option, configure syslog to handle
  messages if not done.
6  Watch /var/log/messages, nothing but lcp-echo-request.

Actual Results:  As above: no connection, just lcp-echo-requests in
/var/log/messages.

Expected Results:  Connection OK, normal connection dialog logged by syslog with
interspersed lcp-echo-requests. Also: PPP link disconnected if physical link
broken despite lack of correct hardware signals (DCD/DSR/DTR) handling.

Additional info:

A typical notebook setup: No fixed serial port, but a USB one on the machine.
Connection through a cellular phone to ISP

Comment 1 MIchael Kolmodin 2002-12-03 23:50:34 UTC
pppd version 2.4.1


Comment 2 MIchael Kolmodin 2002-12-04 16:41:20 UTC
Oops, don't know why, but now it works for me. Close the bug, I will reopen it
if it occur again (and I understand why...)


Note You need to log in before you can comment on or make changes to this bug.