Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78950 - the default skernel src.rpm's do not build all targets on an i686
Summary: the default skernel src.rpm's do not build all targets on an i686
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-03 21:20 UTC by Phil Copeland
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-04 02:00:56 UTC


Attachments (Terms of Use)

Description Phil Copeland 2002-12-03 21:20:31 UTC
Description of Problem:
The default kernel src.rpm's do not build all targets on an i686

I'm using a i686 box to rebuild the kernel-2.4.18-8.0.src.rpm
expecting to obtain the standard *.i686.rpm stuff that you would normally
get off the RHN updates ftp site

by default the rpmbuild --rebuild kernel-2.4.18-18.8.0.src.rpm
produces the src.rpm, the doc and headers and ONLY the BOOT kernel

I know that rpmbuild --target=i686 --rebuild kernel-2.4.18-18.8.0.src.rpm
will generate the rpm's thats I want but I'm curious as to if this is something
that I'm supposed to stipulate originally or if rpm is supposed to work out
'gosh, a i686!' and automagically insert that option.

If (as I suspect) this isn't rpm's fault then please reassign to the kernel folk
where I'd like to suggest that this type of information should be part of the
initial build output ie

"Build will produce X,Y,Z rpm's'
"To build i586 use --target=i586"
"To build i686 and debug kernel use --target=i686"

Something like that because it's not obvious or directly explained in
documentation what to do to obtain the 686/debug/i586/up/smp/(also true in AS)
enterprise kernels fom the src.rpm

Version-Release number of selected component (if applicable):

rpm -q rpm
rpm-4.1-1.06


How Reproducible:
On an i686, expecting to build 
rpmbuild --rebuild kernel-2.4.18-18.8.0.src.rpm


Actual Results:
Wrote: /usr/src/redhat/RPMS/i386/kernel-2.4.18-18.8.0.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/kernel-source-2.4.18-18.8.0.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/kernel-doc-2.4.18-18.8.0.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/kernel-BOOT-2.4.18-18.8.0.i386.rpm



Expected Results:
Wrote: /usr/src/redhat/RPMS/i686/kernel-2.4.18-18.8.0.i686.rpm
Wrote: /usr/src/redhat/RPMS/i686/kernel-smp-2.4.18-18.8.0.i686.rpm
Wrote: /usr/src/redhat/RPMS/i686/kernel-bigmem-2.4.18-18.8.0.i686.rpm
Wrote: /usr/src/redhat/RPMS/i686/kernel-uml-2.4.18-18.8.0.i686.rpm
Wrote: /usr/src/redhat/RPMS/i686/kernel-debug-2.4.18-18.8.0.i686.rpm


Additional Information:
I'm being fussy?

Phil
=--=

Comment 1 Jeff Johnson 2002-12-04 02:00:49 UTC
Hi Phil!

rpm uses the canonical target -- i386 -- by default.

Everything else is done within package and/or invocation
config.


Note You need to log in before you can comment on or make changes to this bug.