Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7895 - intellimouse locks up on logout
Summary: intellimouse locks up on logout
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-20 07:07 UTC by Alex
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-14 17:42:23 UTC


Attachments (Terms of Use)

Description Alex 1999-12-20 07:07:33 UTC
I am using a Microsoft intellimouse PS/2 and an STB Velocity graphics card
(riva128, 8 mb). All hardware is from Dell.
The mouse functioned flawlessly in RedHat 5.2 with XFree86 3.3.3-1,
including scrolling with the mouse wheel. Upon upgrading to RedHat 6.1, the
following started to happen. When I log out of my window manager, if I move
the mouse while the system is switching into xdm, the pointer zooms to the
right top corner of the screen and stays there. The only way for me to
regain the use of my mouse is to move the mouse wheel up a notch (!) :).
This does not happen if I keep the mouse still during the logout process.
Adding various things to my XF86Config file, such as "sw_cursor", made no
difference. I suspect the problem is with XFree86 3.3.5 nvidia riva driver.
This is not a severe problem, since no other application seems to be
affected, just annoying every time it happens. One obvious solution is to
downgrade to XFree86 3.3.3-1.

Comment 1 Preston Brown 2000-01-14 17:42:59 UTC
mouse handling has been tweaked for 3.3.6.  When it is available, please test
again and see if the problem has been resolved.  If not, reopen the bug and
we'll dig deeper.

Comment 2 Alex 2000-03-05 21:59:59 UTC
The bug persists with XFree86-SVGA-3.3.6-11.i386.rpm. Needs to be reopenned.
Once again, XFree86 3.3.3-1 is working fine.


Note You need to log in before you can comment on or make changes to this bug.