Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7894 - lilo-0.21-10 truncates command lines to 79 characters
Summary: lilo-0.21-10 truncates command lines to 79 characters
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lilo
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 8305 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-20 06:46 UTC by Chris Siebenmann
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-04-12 05:40:04 UTC


Attachments (Terms of Use)

Description Chris Siebenmann 1999-12-20 06:46:48 UTC
The version of lilo shipped with Redhat 6.1 truncates the
kernel command line to 79 characters. This can have various
bad results, especially if it chops off a parameter in the
middle; it likely the root cause of bugs #7032 and #5747.

 A report on the linux-kernel mailing list suggests that
this is the fault of the EBDA patch.

Comment 1 Cristian Gafton 2000-01-04 22:26:59 UTC
Assigned to dledford

Comment 2 Brock Organ 2000-05-22 19:22:59 UTC
verified problem using lilo-21.4.1-2 ... so sample prompt as here

LILO Boot: linux reconfig

expanded to (in /proc/cmdline):

BOOT_IMAGE=linux ro root=305 BOOT_FILE=/boot/vmlinuz-2.2.14-100 mem=60m reconf

         1         2         3         4         5         6         7         8
12345678901234567890123456789012345678901234567890123456789012345678901234567890

note the truncation of reconfig ...

Comment 3 Jeremy Katz 2002-04-12 05:40:00 UTC
*** Bug 8305 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2002-06-04 06:06:32 UTC
Fixed in newer lilo packages


Note You need to log in before you can comment on or make changes to this bug.